python-treq: bump to version 16.12.0
[buildroot-gz.git] / package / icu / icu.mk
blobb9e42de94b2339e2966c90e0edaa588eac09a857
1 ################################################################################
3 # icu
5 ################################################################################
7 ICU_VERSION = 58.2
8 ICU_SOURCE = icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz
9 ICU_SITE = http://download.icu-project.org/files/icu4c/$(ICU_VERSION)
10 ICU_LICENSE = ICU License
11 ICU_LICENSE_FILES = license.html
13 ICU_DEPENDENCIES = host-icu
14 ICU_INSTALL_STAGING = YES
15 ICU_CONFIG_SCRIPTS = icu-config
16 ICU_CONF_OPTS = \
17 --with-cross-build=$(HOST_ICU_DIR)/source \
18 --disable-samples \
19 --disable-tests
21 # When available, icu prefers to use C++11 atomics, which rely on the
22 # __atomic builtins. On certain architectures, this requires linking
23 # with libatomic starting from gcc 4.8.
24 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
25 ICU_CONF_ENV += LIBS="-latomic"
26 endif
28 # strtod_l() is not supported by musl; also xlocale.h is missing
29 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
30 ICU_CONF_ENV += ac_cv_func_strtod_l=no
31 endif
33 HOST_ICU_CONF_OPTS = \
34 --disable-samples \
35 --disable-tests \
36 --disable-extras \
37 --disable-icuio \
38 --disable-layout \
39 --disable-renaming
40 ICU_SUBDIR = source
41 HOST_ICU_SUBDIR = source
43 ICU_CUSTOM_DATA_PATH = $(call qstrip,$(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH))
45 ifneq ($(ICU_CUSTOM_DATA_PATH),)
46 define ICU_COPY_CUSTOM_DATA
47 cp $(ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
48 endef
49 ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
50 endif
52 define ICU_REMOVE_DEV_FILES
53 rm -f $(addprefix $(TARGET_DIR)/usr/bin/,derb genbrk gencfu gencnval gendict genrb icuinfo makeconv uconv)
54 rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,genccode gencmn gennorm2 gensprep icupkg)
55 rm -rf $(TARGET_DIR)/usr/share/icu
56 endef
57 ICU_POST_INSTALL_TARGET_HOOKS += ICU_REMOVE_DEV_FILES
59 $(eval $(autotools-package))
60 $(eval $(host-autotools-package))