1 ################################################################################
5 ################################################################################
7 LIBXSLT_VERSION
= 1.1.29
8 LIBXSLT_SITE
= ftp
://xmlsoft.org
/libxslt
9 LIBXSLT_INSTALL_STAGING
= YES
11 LIBXSLT_LICENSE_FILES
= COPYING
17 --with-libxml-prefix
=$(STAGING_DIR
)/usr
/ \
18 --with-libxml-libs-prefix
=$(STAGING_DIR
)/usr
/lib
19 LIBXSLT_CONFIG_SCRIPTS
= xslt-config
20 LIBXSLT_DEPENDENCIES
= libxml2
22 # GCC bug with Os/O2/O3, PR77311
23 # error: unable to find a register to spill in class 'CCREGS'
25 LIBXSLT_CONF_ENV
+= CFLAGS
="$(TARGET_CFLAGS) -O1"
28 # If we have enabled libgcrypt then use it, else disable crypto support.
29 ifeq ($(BR2_PACKAGE_LIBGCRYPT
),y
)
30 LIBXSLT_DEPENDENCIES
+= libgcrypt
31 LIBXSLT_CONF_ENV
+= LIBGCRYPT_CONFIG
=$(STAGING_DIR
)/usr
/bin
/libgcrypt-config
33 LIBXSLT_CONF_OPTS
+= --without-crypto
36 HOST_LIBXSLT_CONF_OPTS
= --without-debug
--without-python
--without-crypto
38 HOST_LIBXSLT_DEPENDENCIES
= host-libxml2
40 $(eval
$(autotools-package
))
41 $(eval
$(host-autotools-package
))