1 ################################################################################
5 ################################################################################
8 RTAI_SOURCE
= rtai-
$(RTAI_VERSION
).
tar.bz2
9 RTAI_SITE
= https
://www.rtai.org
/userfiles
/downloads
/RTAI
10 RTAI_INSTALL_STAGING
= YES
12 # The <pkg>_CONFIG_SCRIPTS cannot apply here to the specificities of rtai-config
13 define RTAI_POST_PATCH_FIXUP
14 $(SED
) 's%^staging=.*%staging=$(STAGING_DIR)%' $(STAGING_DIR
)/usr
/bin
/rtai-config
17 RTAI_POST_INSTALL_STAGING_HOOKS
+= RTAI_POST_PATCH_FIXUP
19 RTAI_DEPENDENCIES
= linux
22 --includedir=/usr
/include/rtai \
23 --with-linux-dir
=$(LINUX_DIR
) \
26 --enable-align-priority \
28 --with-module-dir
=/lib
/modules
/$(LINUX_VERSION_PROBED
)/rtai
32 $(eval
$(autotools-package
))