python-treq: bump to version 16.12.0
[buildroot-gz.git] / package / rtai / rtai.mk
blobdfd8e0c19082621de88c160d4e059386d8b8cbbf
1 ################################################################################
3 # rtai
5 ################################################################################
7 RTAI_VERSION = 4.0.1
8 RTAI_SOURCE = rtai-$(RTAI_VERSION).tar.bz2
9 RTAI_SITE = https://www.rtai.org/userfiles/downloads/RTAI
10 RTAI_INSTALL_STAGING = YES
12 # The <pkg>_CONFIG_SCRIPTS cannot apply here to the specificities of rtai-config
13 define RTAI_POST_PATCH_FIXUP
14 $(SED) 's%^staging=.*%staging=$(STAGING_DIR)%' $(STAGING_DIR)/usr/bin/rtai-config
15 endef
17 RTAI_POST_INSTALL_STAGING_HOOKS += RTAI_POST_PATCH_FIXUP
19 RTAI_DEPENDENCIES = linux
21 RTAI_CONF_OPTS = \
22 --includedir=/usr/include/rtai \
23 --with-linux-dir=$(LINUX_DIR) \
24 --disable-leds \
25 --enable-usi \
26 --enable-align-priority \
27 --disable-rtailab \
28 --with-module-dir=/lib/modules/$(LINUX_VERSION_PROBED)/rtai
30 RTAI_MAKE = $(MAKE1)
32 $(eval $(autotools-package))