1 ################################################################################
5 ################################################################################
7 SHAIRPORT_SYNC_VERSION
= 2.8.6
8 SHAIRPORT_SYNC_SITE
= $(call github
,mikebrady
,shairport-sync
,$(SHAIRPORT_SYNC_VERSION
))
10 SHAIRPORT_SYNC_LICENSE
= MIT
, BSD-3c
11 SHAIRPORT_SYNC_LICENSE_FILES
= LICENSES
12 SHAIRPORT_SYNC_DEPENDENCIES
= alsa-lib libconfig libdaemon popt host-pkgconf
14 # git clone, no configure
15 SHAIRPORT_SYNC_AUTORECONF
= YES
17 SHAIRPORT_SYNC_CONF_OPTS
= --with-alsa \
22 # Avahi or tinysvcmdns (shaiport-sync bundles its own version of tinysvcmdns).
23 # Avahi support needs libavahi-client, which is built by avahi if avahi-daemon
24 # and dbus is selected. Since there is no BR2_PACKAGE_LIBAVAHI_CLIENT config
25 # option yet, use the avahi-daemon and dbus congig symbols to check for
27 ifeq ($(BR2_PACKAGE_AVAHI_DAEMON
)$(BR2_PACKAGE_DBUS
),yy
)
28 SHAIRPORT_SYNC_DEPENDENCIES
+= avahi
29 SHAIRPORT_SYNC_CONF_OPTS
+= --with-avahi
31 SHAIRPORT_SYNC_CONF_OPTS
+= --with-tinysvcmdns
35 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
36 SHAIRPORT_SYNC_DEPENDENCIES
+= openssl
37 SHAIRPORT_SYNC_CONF_OPTS
+= --with-ssl
=openssl
39 SHAIRPORT_SYNC_DEPENDENCIES
+= polarssl
40 SHAIRPORT_SYNC_CONF_OPTS
+= --with-ssl
=polarssl
43 ifeq ($(BR2_PACKAGE_SHAIRPORT_SYNC_LIBSOXR
),y
)
44 SHAIRPORT_SYNC_DEPENDENCIES
+= libsoxr
45 SHAIRPORT_SYNC_CONF_OPTS
+= --with-soxr
48 define SHAIRPORT_SYNC_INSTALL_TARGET_CMDS
49 $(INSTALL
) -D
-m
0755 $(@D
)/shairport-sync \
50 $(TARGET_DIR
)/usr
/bin
/shairport-sync
51 $(INSTALL
) -D
-m
0644 $(@D
)/scripts
/shairport-sync.conf \
52 $(TARGET_DIR
)/etc
/shairport-sync.conf
55 define SHAIRPORT_SYNC_INSTALL_INIT_SYSV
56 $(INSTALL
) -D
-m
0755 package
/shairport-sync
/S99shairport-sync \
57 $(TARGET_DIR
)/etc
/init.d
/S99shairport-sync
60 $(eval
$(autotools-package
))