gnuplot: bump version to 5.0.5
[buildroot-gz.git] / package / gnuplot / gnuplot.mk
blob3e00eefef828276fec7dc51094c71bb3f7831aca
1 ################################################################################
3 # gnuplot
5 ################################################################################
7 GNUPLOT_VERSION = 5.0.5
8 GNUPLOT_SITE = http://downloads.sourceforge.net/project/gnuplot/gnuplot/$(GNUPLOT_VERSION)
9 GNUPLOT_LICENSE = gnuplot license (open source)
10 GNUPLOT_LICENSE_FILES = Copyright
12 GNUPLOT_AUTORECONF = YES
14 GNUPLOT_CONF_OPTS = \
15 --without-x \
16 --disable-raise-console \
17 --disable-mouse \
18 --without-tutorial \
19 --disable-demo \
20 --without-row-help \
21 --disable-history-file \
22 --disable-wxwidgets \
23 --without-lua \
24 --without-latex \
25 --without-cairo
27 # relocation truncated to fit: R_68K_GOT16O
28 ifeq ($(BR2_m68k_cf),y)
29 GNUPLOT_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -mxgot"
30 endif
32 ifeq ($(BR2_PACKAGE_GD)$(BR2_PACKAGE_LIBPNG),yy)
33 GNUPLOT_CONF_OPTS += --with-gd
34 GNUPLOT_DEPENDENCIES += gd
35 GNUPLOT_CONF_ENV += \
36 ac_cv_path_GDLIB_CONFIG=$(STAGING_DIR)/usr/bin/gdlib-config
37 else
38 GNUPLOT_CONF_OPTS += --without-gd
39 endif
41 ifeq ($(BR2_PACKAGE_READLINE),y)
42 GNUPLOT_CONF_OPTS += --with-readline=gnu
43 GNUPLOT_DEPENDENCIES += readline
44 else
45 GNUPLOT_CONF_OPTS += --without-readline
46 endif
48 # Remove Javascript scripts, lua scripts, PostScript files
49 define GNUPLOT_REMOVE_UNNEEDED_FILES
50 $(RM) -rf $(TARGET_DIR)/usr/share/gnuplot
51 endef
53 GNUPLOT_POST_INSTALL_TARGET_HOOKS += GNUPLOT_REMOVE_UNNEEDED_FILES
55 $(eval $(autotools-package))