debianutils: bump to version 4.8.1
[buildroot-gz.git] / package / libshout / libshout.mk
blobbf85595204648e57f8f7dc580b7df2707ef8ae8d
1 ################################################################################
3 # libshout
5 ################################################################################
7 LIBSHOUT_VERSION = 2.4.1
8 LIBSHOUT_SITE = http://downloads.xiph.org/releases/libshout
9 LIBSHOUT_LICENSE = LGPLv2+
10 LIBSHOUT_LICENSE_FILES = COPYING
11 LIBSHOUT_INSTALL_STAGING = YES
12 LIBSHOUT_DEPENDENCIES = host-pkgconf libogg libvorbis
14 # patching configure.ac
15 LIBSHOUT_AUTORECONF = YES
17 ifeq ($(BR2_PACKAGE_LIBTHEORA),y)
18 LIBSHOUT_CONF_OPTS += --enable-theora
19 LIBSHOUT_DEPENDENCIES += libtheora
20 else
21 LIBSHOUT_CONF_OPTS += --disable-theora
22 endif
24 ifeq ($(BR2_PACKAGE_SPEEX),y)
25 LIBSHOUT_CONF_OPTS += --enable-speex
26 LIBSHOUT_DEPENDENCIES += speex
27 else
28 LIBSHOUT_CONF_OPTS += --disable-speex
29 endif
31 ifeq ($(BR2_PACKAGE_OPENSSL),y)
32 LIBSHOUT_CONF_OPTS += --with-openssl
33 LIBSHOUT_DEPENDENCIES += openssl
34 else
35 LIBSHOUT_CONF_OPTS += --without-openssl
36 endif
38 $(eval $(autotools-package))