debianutils: bump to version 4.8.1
[buildroot-gz.git] / package / weston / weston.mk
blob7d348dc10e525e28bbcb2b07e0672c93a2ce7915
1 ################################################################################
3 # weston
5 ################################################################################
7 WESTON_VERSION = 1.12.0
8 WESTON_SITE = http://wayland.freedesktop.org/releases
9 WESTON_SOURCE = weston-$(WESTON_VERSION).tar.xz
10 WESTON_LICENSE = MIT
11 WESTON_LICENSE_FILES = COPYING
13 WESTON_DEPENDENCIES = host-pkgconf wayland wayland-protocols \
14 libxkbcommon pixman libpng jpeg mtdev udev cairo libinput \
15 $(if $(BR2_PACKAGE_WEBP),webp)
17 WESTON_CONF_OPTS = \
18 --with-dtddir=$(STAGING_DIR)/usr/share/wayland \
19 --disable-headless-compositor \
20 --disable-colord \
21 --disable-setuid-install
23 WESTON_MAKE_OPTS = \
24 WAYLAND_PROTOCOLS_DATADIR=$(STAGING_DIR)/usr/share/wayland-protocols
26 # Uses VIDIOC_EXPBUF, only available from 3.8+
27 ifeq ($(BR2_TOOLCHAIN_HEADERS_AT_LEAST_3_8),)
28 WESTON_CONF_OPTS += --disable-simple-dmabuf-v4l-client
29 endif
31 ifeq ($(BR2_PACKAGE_DBUS),y)
32 WESTON_CONF_OPTS += --enable-dbus
33 WESTON_DEPENDENCIES += dbus
34 else
35 WESTON_CONF_OPTS += --disable-dbus
36 endif
38 # weston-launch must be u+s root in order to work properly
39 ifeq ($(BR2_PACKAGE_LINUX_PAM),y)
40 define WESTON_PERMISSIONS
41 /usr/bin/weston-launch f 4755 0 0 - - - - -
42 endef
43 define WESTON_USERS
44 - - weston-launch -1 - - - - Weston launcher group
45 endef
46 WESTON_CONF_OPTS += --enable-weston-launch
47 WESTON_DEPENDENCIES += linux-pam
48 else
49 WESTON_CONF_OPTS += --disable-weston-launch
50 endif
52 # Needs wayland-egl, which normally only mesa provides
53 ifeq ($(BR2_PACKAGE_MESA3D_OPENGL_EGL)$(BR2_PACKAGE_MESA3D_OPENGL_ES),yy)
54 WESTON_CONF_OPTS += --enable-egl
55 WESTON_DEPENDENCIES += libegl
56 else
57 WESTON_CONF_OPTS += \
58 --disable-egl \
59 --disable-simple-egl-clients
60 endif
62 ifeq ($(BR2_PACKAGE_LIBUNWIND),y)
63 WESTON_DEPENDENCIES += libunwind
64 else
65 WESTON_CONF_OPTS += --disable-libunwind
66 endif
68 ifeq ($(BR2_PACKAGE_WESTON_RDP),y)
69 WESTON_DEPENDENCIES += freerdp
70 WESTON_CONF_OPTS += --enable-rdp-compositor
71 else
72 WESTON_CONF_OPTS += --disable-rdp-compositor
73 endif
75 ifeq ($(BR2_PACKAGE_WESTON_FBDEV),y)
76 WESTON_CONF_OPTS += \
77 --enable-fbdev-compositor \
78 WESTON_NATIVE_BACKEND=fbdev-backend.so
79 else
80 WESTON_CONF_OPTS += --disable-fbdev-compositor
81 endif
83 ifeq ($(BR2_PACKAGE_WESTON_DRM),y)
84 WESTON_CONF_OPTS += \
85 --enable-drm-compositor \
86 WESTON_NATIVE_BACKEND=drm-backend.so
87 WESTON_DEPENDENCIES += libdrm
88 else
89 WESTON_CONF_OPTS += --disable-drm-compositor
90 endif
92 ifeq ($(BR2_PACKAGE_WESTON_X11),y)
93 WESTON_CONF_OPTS += \
94 --enable-x11-compositor \
95 WESTON_NATIVE_BACKEND=x11-backend.so
96 WESTON_DEPENDENCIES += libxcb xlib_libX11
97 else
98 WESTON_CONF_OPTS += --disable-x11-compositor
99 endif
101 ifeq ($(BR2_PACKAGE_WESTON_XWAYLAND),y)
102 WESTON_CONF_OPTS += --enable-xwayland
103 WESTON_DEPENDENCIES += cairo libepoxy libxcb xlib_libX11 xlib_libXcursor
104 else
105 WESTON_CONF_OPTS += --disable-xwayland
106 endif
108 ifeq ($(BR2_PACKAGE_LIBVA),y)
109 WESTON_CONF_OPTS += --enable-vaapi-recorder
110 WESTON_DEPENDENIES += libva
111 else
112 WESTON_CONF_OPTS += --disable-vaapi-recorder
113 endif
115 ifeq ($(BR2_PACKAGE_LCMS2),y)
116 WESTON_CONF_OPTS += --enable-lcms
117 WESTON_DEPENDENCIES += lcms2
118 else
119 WESTON_CONF_OPTS += --disable-lcms
120 endif
122 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
123 WESTON_CONF_OPTS += --enable-systemd-login --enable-systemd-notify
124 WESTON_DEPENDENCIES += systemd
125 else
126 WESTON_CONF_OPTS += --disable-systemd-login --disable-systemd-notify
127 endif
129 ifeq ($(BR2_PACKAGE_LIBXML2),y)
130 WESTON_CONF_OPTS += --enable-junit-xml
131 WESTON_DEPENDENCIES += libxml2
132 else
133 WESTON_CONF_OPTS += --disable-junit-xml
134 endif
136 ifeq ($(BR2_PACKAGE_WESTON_DEMO_CLIENTS),y)
137 WESTON_CONF_OPTS += --enable-demo-clients-install
138 else
139 WESTON_CONF_OPTS += --disable-demo-clients-install
140 endif
142 $(eval $(autotools-package))