1 ################################################################################
5 ################################################################################
7 PROTOBUF_VERSION
= v2.6
.1
8 PROTOBUF_SITE
= $(call github
,google
,protobuf
,$(PROTOBUF_VERSION
))
9 PROTOBUF_LICENSE
= BSD-3c
10 PROTOBUF_LICENSE_FILES
= LICENSE
12 PROTOBUF_AUTORECONF
= YES
14 # N.B. Need to use host protoc during cross compilation.
15 PROTOBUF_DEPENDENCIES
= host-protobuf
16 PROTOBUF_CONF_OPTS
= --with-protoc
=$(HOST_DIR
)/usr
/bin
/protoc
18 PROTOBUF_INSTALL_STAGING
= YES
20 ifeq ($(BR2_PACKAGE_ZLIB
),y
)
21 PROTOBUF_DEPENDENCIES
+= zlib
24 $(eval
$(autotools-package
))
25 $(eval
$(host-autotools-package
))