1 ################################################################################
5 ################################################################################
7 JANUS_GATEWAY_VERSION
= v0.2
.1
8 JANUS_GATEWAY_SITE
= $(call github
,meetecho
,janus-gateway
,$(JANUS_GATEWAY_VERSION
))
9 JANUS_GATEWAY_LICENSE
= GPLv3
10 JANUS_GATEWAY_LICENSE_FILES
= COPYING
12 # ding-libs provides the ini_config library
13 JANUS_GATEWAY_DEPENDENCIES
= host-pkgconf jansson libnice \
14 libsrtp host-gengetopt libglib2 openssl
16 # Straight out of the repository, no ./configure, and we also patch
18 JANUS_GATEWAY_AUTORECONF
= YES
20 define JANUS_GATEWAY_M4
23 JANUS_GATEWAY_POST_PATCH_HOOKS
+= JANUS_GATEWAY_M4
25 JANUS_GATEWAY_CONF_OPTS
= \
26 --disable-data-channels \
29 ifeq ($(BR2_PACKAGE_JANUS_AUDIO_BRIDGE
),y
)
30 JANUS_GATEWAY_DEPENDENCIES
+= opus
31 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-audiobridge
33 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-audiobridge
36 ifeq ($(BR2_PACKAGE_JANUS_ECHO_TEST
),y
)
37 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-echotest
39 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-echotest
42 ifeq ($(BR2_PACKAGE_JANUS_RECORDPLAY
),y
)
43 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-recordplay
45 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-recordplay
48 ifeq ($(BR2_PACKAGE_JANUS_SIP_GATEWAY
),y
)
49 JANUS_GATEWAY_DEPENDENCIES
+= sofia-sip
50 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-sip
52 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-sip
55 ifeq ($(BR2_PACKAGE_JANUS_STREAMING
),y
)
56 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-streaming
58 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-streaming
61 ifeq ($(BR2_PACKAGE_JANUS_TEXT_ROOM
),y
)
62 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-textroom
64 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-textroom
67 ifeq ($(BR2_PACKAGE_JANUS_VIDEO_CALL
),y
)
68 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-videocall
70 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-videocall
73 ifeq ($(BR2_PACKAGE_JANUS_VIDEO_ROOM
),y
)
74 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-videoroom
76 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-videoroom
79 ifeq ($(BR2_PACKAGE_JANUS_VOICE_MAIL
),y
)
80 JANUS_GATEWAY_DEPENDENCIES
+= libogg
81 JANUS_GATEWAY_CONF_OPTS
+= --enable-plugin-voicemail
83 JANUS_GATEWAY_CONF_OPTS
+= --disable-plugin-voicemail
86 ifeq ($(BR2_PACKAGE_LIBWEBSOCKETS
),y
)
87 JANUS_GATEWAY_DEPENDENCIES
+= libwebsockets
88 JANUS_GATEWAY_CONF_OPTS
+= --enable-websockets
90 JANUS_GATEWAY_CONF_OPTS
+= --disable-websockets
93 # Parallel build broken
94 JANUS_GATEWAY_MAKE
= $(MAKE1
)
96 $(eval
$(autotools-package
))