python-pathvalidate: bump version to 0.14.1
[buildroot-gz.git] / package / openvpn / openvpn.mk
blob5e3df59f30ddea51856037d9eb44dfe7e68c4143
1 ################################################################################
3 # openvpn
5 ################################################################################
7 OPENVPN_VERSION = 2.4.0
8 OPENVPN_SOURCE = openvpn-$(OPENVPN_VERSION).tar.xz
9 OPENVPN_SITE = http://swupdate.openvpn.net/community/releases
10 OPENVPN_DEPENDENCIES = host-pkgconf openssl
11 OPENVPN_LICENSE = GPLv2
12 OPENVPN_LICENSE_FILES = COPYRIGHT.GPL
13 OPENVPN_CONF_OPTS = \
14 --disable-plugin-auth-pam \
15 --enable-iproute2 \
16 --with-crypto-library=openssl \
17 $(if $(BR2_STATIC_LIBS),--disable-plugins)
18 OPENVPN_CONF_ENV = IFCONFIG=/sbin/ifconfig \
19 NETSTAT=/bin/netstat \
20 ROUTE=/sbin/route
22 ifeq ($(BR2_PACKAGE_OPENVPN_SMALL),y)
23 OPENVPN_CONF_OPTS += \
24 --enable-small \
25 --disable-plugins \
26 --disable-eurephia
27 endif
29 # BusyBox 1.21+ places the ip applet in the "correct" place
30 # but previous versions didn't.
31 ifeq ($(BR2_PACKAGE_IPROUTE2),y)
32 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
33 else ifeq ($(BR2_BUSYBOX_VERSION_1_19_X)$(BR2_BUSYBOX_VERSION_1_20_X),y)
34 OPENVPN_CONF_ENV += IPROUTE=/bin/ip
35 else
36 OPENVPN_CONF_ENV += IPROUTE=/sbin/ip
37 endif
39 ifeq ($(BR2_PACKAGE_OPENVPN_LZO),y)
40 OPENVPN_DEPENDENCIES += lzo
41 else
42 OPENVPN_CONF_OPTS += --disable-lzo
43 endif
45 define OPENVPN_INSTALL_TARGET_CMDS
46 $(INSTALL) -m 755 $(@D)/src/openvpn/openvpn \
47 $(TARGET_DIR)/usr/sbin/openvpn
48 endef
50 define OPENVPN_INSTALL_INIT_SYSV
51 $(INSTALL) -m 755 -D package/openvpn/S60openvpn \
52 $(TARGET_DIR)/etc/init.d/S60openvpn
53 endef
55 $(eval $(autotools-package))