python-pathvalidate: bump version to 0.14.1
[buildroot-gz.git] / package / stress-ng / stress-ng.mk
blobb4d469938314c387a4c0c90ed7ffdf060c0547fb
1 ################################################################################
3 # stress-ng
5 ################################################################################
7 STRESS_NG_VERSION = 0.06.15
8 STRESS_NG_SITE = http://kernel.ubuntu.com/~cking/tarballs/stress-ng
9 STRESS_NG_LICENSE = GPLv2+
10 STRESS_NG_LICENSE_FILES = COPYING
12 STRESS_NG_DEPENDENCIES = attr keyutils
14 define STRESS_NG_BUILD_CMDS
15 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D)
16 endef
18 # Don't use make install otherwise stress-ng will be rebuild without
19 # required link libraries if any. Furthermore, using INSTALL allow to
20 # set the file permission correcly on the target.
21 define STRESS_NG_INSTALL_TARGET_CMDS
22 $(INSTALL) -m 0755 -D $(@D)/stress-ng $(TARGET_DIR)/usr/bin/stress-ng
23 endef
25 $(eval $(generic-package))