ncftp: bump version to 3.2.6
[buildroot-gz.git] / package / icu / icu.mk
blob3b40dfbd8652672107705521213646630f374ce8
1 ################################################################################
3 # icu
5 ################################################################################
7 ICU_VERSION = 57.1
8 ICU_SOURCE = icu4c-$(subst .,_,$(ICU_VERSION))-src.tgz
9 ICU_SITE = http://download.icu-project.org/files/icu4c/$(ICU_VERSION)
10 ICU_LICENSE = ICU License
11 ICU_LICENSE_FILES = license.html
13 ICU_DEPENDENCIES = host-icu
14 ICU_INSTALL_STAGING = YES
15 ICU_CONFIG_SCRIPTS = icu-config
16 ICU_CONF_OPTS = \
17 --with-cross-build=$(HOST_ICU_DIR)/source \
18 --disable-samples \
19 --disable-tests
21 # When available, icu prefers to use C++11 atomics, which rely on the
22 # __atomic builtins. On certain architectures, this requires linking
23 # with libatomic starting from gcc 4.8.
24 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
25 ICU_CONF_ENV += LIBS="-latomic"
26 endif
28 HOST_ICU_CONF_OPTS = \
29 --disable-samples \
30 --disable-tests \
31 --disable-extras \
32 --disable-icuio \
33 --disable-layout \
34 --disable-renaming
35 ICU_SUBDIR = source
36 HOST_ICU_SUBDIR = source
38 ICU_CUSTOM_DATA_PATH = $(call qstrip,$(BR2_PACKAGE_ICU_CUSTOM_DATA_PATH))
40 ifneq ($(ICU_CUSTOM_DATA_PATH),)
41 define ICU_COPY_CUSTOM_DATA
42 cp $(ICU_CUSTOM_DATA_PATH) $(@D)/source/data/in/
43 endef
44 ICU_POST_PATCH_HOOKS += ICU_COPY_CUSTOM_DATA
45 endif
47 define ICU_REMOVE_DEV_FILES
48 rm -f $(addprefix $(TARGET_DIR)/usr/bin/,derb genbrk gencfu gencnval gendict genrb icuinfo makeconv uconv)
49 rm -f $(addprefix $(TARGET_DIR)/usr/sbin/,genccode gencmn gennorm2 gensprep icupkg)
50 rm -rf $(TARGET_DIR)/usr/share/icu
51 endef
52 ICU_POST_INSTALL_TARGET_HOOKS += ICU_REMOVE_DEV_FILES
54 $(eval $(autotools-package))
55 $(eval $(host-autotools-package))