ncftp: bump version to 3.2.6
[buildroot-gz.git] / package / libva / libva.mk
blobcf42b70e843b27a04da133b891c86d360f563ddf
1 ################################################################################
3 # libva
5 ################################################################################
7 LIBVA_VERSION = 1.7.3
8 LIBVA_SOURCE = libva-$(LIBVA_VERSION).tar.bz2
9 LIBVA_SITE = http://www.freedesktop.org/software/vaapi/releases/libva
10 LIBVA_LICENSE = MIT
11 LIBVA_LICENSE_FILES = COPYING
12 LIBVA_AUTORECONF = YES
13 LIBVA_INSTALL_STAGING = YES
14 LIBVA_DEPENDENCIES = host-pkgconf libdrm
16 # libdrm is a hard-dependency
17 LIBVA_CONF_OPTS = \
18 --enable-drm \
19 --disable-dummy-driver \
20 --with-drivers-path="/usr/lib/va"
22 ifeq ($(BR2_PACKAGE_MESA3D_DRI_DRIVER),y)
23 LIBVA_DEPENDENCIES += mesa3d
24 LIBVA_CONF_OPTS += --enable-glx
25 else
26 LIBVA_CONF_OPTS += --disable-glx
27 endif
29 ifeq ($(BR2_PACKAGE_XORG7),y)
30 LIBVA_DEPENDENCIES += xlib_libX11 xlib_libXext xlib_libXfixes
31 LIBVA_CONF_OPTS += --enable-x11
32 else
33 LIBVA_CONF_OPTS += --disable-x11
34 endif
36 ifeq ($(BR2_PACKAGE_WAYLAND),y)
37 LIBVA_DEPENDENCIES += wayland
38 LIBVA_CONF_OPTS += --enable-wayland
39 else
40 LIBVA_CONF_OPTS += --disable-wayland
41 endif
43 ifeq ($(BR2_PACKAGE_HAS_LIBEGL),y)
44 LIBVA_DEPENDENCIES += libegl
45 LIBVA_CONF_OPTS += --enable-egl
46 else
47 LIBVA_CONF_OPTS += --disable-egl
48 endif
50 # Autoreconf requires an m4 directory to exist
51 define LIBVA_PATCH_M4
52 mkdir -p $(@D)/m4
53 endef
54 LIBVA_POST_PATCH_HOOKS += LIBVA_PATCH_M4
56 $(eval $(autotools-package))