1 ################################################################################
5 ################################################################################
8 LXC_SITE
= https
://linuxcontainers.org
/downloads
/lxc
9 LXC_LICENSE
= LGPLv2.1
+
10 LXC_LICENSE_FILES
= COPYING
11 LXC_DEPENDENCIES
= libcap host-pkgconf
12 # we're patching configure.ac
14 LXC_CONF_OPTS
= --disable-apparmor
--with-distro
=buildroot \
15 --disable-lua
--disable-python
--disable-werror \
16 $(if
$(BR2_PACKAGE_BASH
),,--disable-bash
)
18 ifeq ($(BR2_PACKAGE_LIBSECCOMP
),y
)
19 LXC_CONF_OPTS
+= --enable-seccomp
20 LXC_DEPENDENCIES
+= libseccomp
22 LXC_CONF_OPTS
+= --disable-seccomp
25 $(eval
$(autotools-package
))