ncftp: bump version to 3.2.6
[buildroot-gz.git] / package / lxc / lxc.mk
blob9e21fc02349a2860b4db01d2e32f5dd2888a38bb
1 ################################################################################
3 # lxc
5 ################################################################################
7 LXC_VERSION = 2.0.3
8 LXC_SITE = https://linuxcontainers.org/downloads/lxc
9 LXC_LICENSE = LGPLv2.1+
10 LXC_LICENSE_FILES = COPYING
11 LXC_DEPENDENCIES = libcap host-pkgconf
12 # we're patching configure.ac
13 LXC_AUTORECONF = YES
14 LXC_CONF_OPTS = --disable-apparmor --with-distro=buildroot \
15 --disable-lua --disable-python --disable-werror \
16 $(if $(BR2_PACKAGE_BASH),,--disable-bash)
18 ifeq ($(BR2_PACKAGE_LIBSECCOMP),y)
19 LXC_CONF_OPTS += --enable-seccomp
20 LXC_DEPENDENCIES += libseccomp
21 else
22 LXC_CONF_OPTS += --disable-seccomp
23 endif
25 $(eval $(autotools-package))