ncftp: bump version to 3.2.6
[buildroot-gz.git] / package / poppler / poppler.mk
blob202eac29d1ff8ec80bb672dbd7d96968527a2b9a
1 ################################################################################
3 # poppler
5 ################################################################################
7 POPPLER_VERSION = 0.48.0
8 POPPLER_SOURCE = poppler-$(POPPLER_VERSION).tar.xz
9 POPPLER_SITE = http://poppler.freedesktop.org
10 POPPLER_DEPENDENCIES = fontconfig host-pkgconf
11 POPPLER_LICENSE = GPLv2+
12 POPPLER_LICENSE_FILES = COPYING
13 POPPLER_INSTALL_STAGING = YES
14 POPPLER_CONF_OPTS = --with-font-configuration=fontconfig \
15 --enable-xpdf-headers
17 ifeq ($(BR2_PACKAGE_CAIRO),y)
18 POPPLER_CONF_OPTS += --enable-cairo-output
19 POPPLER_DEPENDENCIES += cairo
20 else
21 POPLER_CONF_OPTS += --disable-cairo-output
22 endif
24 ifeq ($(BR2_PACKAGE_LCMS2),y)
25 POPPLER_CONF_OPTS += --enable-cms=lcms2
26 POPPLER_DEPENDENCIES += lcms2
27 else
28 POPPLER_CONF_OPTS += --enable-cms=none
29 endif
31 ifeq ($(BR2_PACKAGE_CAIRO)$(BR2_PACKAGE_LIBGLIB2),yy)
32 POPPLER_CONF_OPTS += --enable-poppler-glib
33 POPPLER_DEPENDENCIES += libglib2
34 else
35 POPPLER_CONF_OPTS += --disable-poppler-glib
36 endif
38 ifeq ($(BR2_PACKAGE_TIFF),y)
39 POPPLER_CONF_OPTS += --enable-libtiff
40 # Help poppler to find libtiff in static linking scenarios
41 POPPLER_CONF_ENV += \
42 LIBTIFF_LIBS="`$(PKG_CONFIG_HOST_BINARY) --libs libtiff-4`"
43 POPPLER_DEPENDENCIES += tiff
44 else
45 POPPLER_CONF_OPTS += --disable-libtiff
46 endif
48 ifeq ($(BR2_PACKAGE_JPEG),y)
49 POPPLER_CONF_OPTS += --enable-libjpeg
50 POPPLER_DEPENDENCIES += jpeg
51 else
52 POPPLER_CONF_OPTS += --disable-libjpeg
53 endif
55 ifeq ($(BR2_PACKAGE_LIBPNG),y)
56 POPPLER_CONF_OPTS += --enable-libpng
57 POPPLER_DEPENDENCIES += libpng
58 else
59 POPPLER_CONF_OPTS += --disable-libpng
60 endif
62 ifeq ($(BR2_PACKAGE_ZLIB),y)
63 POPPLER_CONF_OPTS += --enable-zlib
64 POPPLER_DEPENDENCIES += zlib
65 else
66 POPPLER_CONF_OPTS += --disable-zlib
67 endif
69 ifeq ($(BR2_PACKAGE_POPPLER_LIBCURL),y)
70 POPPLER_CONF_OPTS += --enable-libcurl
71 POPPLER_DEPENDENCIES += libcurl
72 else
73 POPPLER_CONF_OPTS += --disable-libcurl
74 endif
76 ifeq ($(BR2_PACKAGE_XORG7),y)
77 POPPLER_CONF_OPTS += --with-x
78 POPPLER_DEPENDENCIES += xlib_libX11 xlib_libXext
79 else
80 POPPLER_CONF_OPTS += --without-x
81 endif
83 ifeq ($(BR2_PACKAGE_POPPLER_QT),y)
84 POPPLER_DEPENDENCIES += qt
85 POPPLER_CONF_OPTS += --enable-poppler-qt4
86 else
87 POPPLER_CONF_OPTS += --disable-poppler-qt4
88 endif
90 ifeq ($(BR2_PACKAGE_OPENJPEG),y)
91 POPPLER_DEPENDENCIES += openjpeg
92 POPPLER_CONF_OPTS += --enable-libopenjpeg
93 else
94 POPPLER_CONF_OPTS += --enable-libopenjpeg=none
95 endif
97 $(eval $(autotools-package))