1 ################################################################################
5 ################################################################################
7 # When upgrading the version, be sure to also upgrade python-rtslib-fb
8 # and python-configshell-fb at the same time.
9 TARGETCLI_FB_VERSION
= v2.1.fb41
10 TARGETCLI_FB_SITE
= $(call github
,open-iscsi
,targetcli-fb
,$(TARGETCLI_FB_VERSION
))
11 TARGETCLI_FB_LICENSE
= Apache-2.0
12 TARGETCLI_FB_LICENSE_FILES
= COPYING
13 TARGETCLI_FB_SETUP_TYPE
= setuptools
14 TARGETCLI_FB_DEPENDENCIES
= python-configshell-fb python-rtslib-fb python-six
16 define TARGETCLI_FB_INSTALL_INIT_SYSV
17 $(INSTALL
) -m
0755 -D package
/targetcli-fb
/S50target \
18 $(TARGET_DIR
)/etc
/init.d
/S50target
21 define TARGETCLI_FB_INSTALL_INIT_SYSTEMD
22 $(INSTALL
) -m
0644 -D package
/targetcli-fb
/target.service \
23 $(TARGET_DIR
)/usr
/lib
/systemd
/system
/target.service
26 # Targetcli stores its configuration in /etc/target/saveconfig.json
27 # and complains if the /etc/target/ directory does not exist.
28 define TARGETCLI_FB_INSTALL_CONF_DIR
29 $(INSTALL
) -m
0755 -d
$(TARGET_DIR
)/etc
/target
32 TARGETCLI_FB_POST_INSTALL_TARGET_HOOKS
+= TARGETCLI_FB_INSTALL_CONF_DIR
34 $(eval
$(python-package
))