ncftp: bump version to 3.2.6
[buildroot-gz.git] / package / zsh / zsh.mk
blobaa4029f1a29651989d0021899b7a2927ea40daa3
1 ################################################################################
3 # zsh
5 ################################################################################
7 ZSH_VERSION = 5.2
8 ZSH_SITE = http://www.zsh.org/pub
9 ZSH_SOURCE = zsh-$(ZSH_VERSION).tar.xz
10 ZSH_DEPENDENCIES = ncurses
11 ZSH_CONF_OPTS = --bindir=/bin
12 # Patching configure.ac
13 ZSH_AUTORECONF = YES
14 ZSH_LICENSE = MIT-like
15 ZSH_LICENSE_FILES = LICENCE
17 ifeq ($(BR2_PACKAGE_GDBM),y)
18 ZSH_CONF_OPTS += --enable-gdbm
19 ZSH_DEPENDENCIES += gdbm
20 else
21 ZSH_CONF_OPTS += --disable-gdbm
22 endif
24 ifeq ($(BR2_PACKAGE_LIBCAP),y)
25 ZSH_CONF_OPTS += --enable-cap
26 ZSH_DEPENDENCIES += libcap
27 else
28 ZSH_CONF_OPTS += --disable-cap
29 endif
31 ifeq ($(BR2_PACKAGE_PCRE),y)
32 ZSH_CONF_OPTS += --enable-pcre
33 ZSH_CONF_ENV += ac_cv_prog_PCRECONF=$(STAGING_DIR)/usr/bin/pcre-config
34 ZSH_DEPENDENCIES += pcre
35 else
36 ZSH_CONF_OPTS += --disable-pcre
37 endif
39 # Remove versioned zsh-x.y.z binary taking up space
40 define ZSH_TARGET_INSTALL_FIXUPS
41 rm -f $(TARGET_DIR)/bin/zsh-$(ZSH_VERSION)
42 endef
43 ZSH_POST_INSTALL_TARGET_HOOKS += ZSH_TARGET_INSTALL_FIXUPS
45 $(eval $(autotools-package))