python: make hashlib and readline modules really optional
[buildroot-gz.git] / package / botan / botan.mk
blob94f1edd2c85db984900dbfee4daa0735e0134c86
1 ################################################################################
3 # botan
5 ################################################################################
7 BOTAN_VERSION = 1.10.13
8 BOTAN_SOURCE = Botan-$(BOTAN_VERSION).tgz
9 BOTAN_SITE = http://botan.randombit.net/releases
10 BOTAN_LICENSE = BSD-2c
11 BOTAN_LICENSE_FILES = doc/license.txt
13 BOTAN_INSTALL_STAGING = YES
15 BOTAN_CONF_OPTS = \
16 --cpu=$(BR2_ARCH) \
17 --os=linux \
18 --cc=gcc \
19 --cc-bin="$(TARGET_CXX)" \
20 --prefix=/usr
22 ifeq ($(BR2_STATIC_LIBS),y)
23 BOTAN_CONF_OPTS += --disable-shared --no-autoload
24 endif
26 ifeq ($(BR2_PACKAGE_BZIP2),y)
27 BOTAN_DEPENDENCIES += bzip2
28 BOTAN_CONF_OPTS += --with-bzip2
29 endif
31 ifeq ($(BR2_PACKAGE_GMP),y)
32 BOTAN_DEPENDENCIES += gmp
33 BOTAN_CONF_OPTS += --with-gnump
34 endif
36 ifeq ($(BR2_PACKAGE_OPENSSL),y)
37 BOTAN_DEPENDENCIES += openssl
38 BOTAN_CONF_OPTS += --with-openssl
39 endif
41 ifeq ($(BR2_PACKAGE_ZLIB),y)
42 BOTAN_DEPENDENCIES += zlib
43 BOTAN_CONF_OPTS += --with-zlib
44 endif
46 define BOTAN_CONFIGURE_CMDS
47 (cd $(@D); $(TARGET_MAKE_ENV) ./configure.py $(BOTAN_CONF_OPTS))
48 endef
50 define BOTAN_BUILD_CMDS
51 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) AR="$(TARGET_AR) crs"
52 endef
54 define BOTAN_INSTALL_STAGING_CMDS
55 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(STAGING_DIR)/usr" install
56 endef
58 define BOTAN_INSTALL_TARGET_CMDS
59 $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)/usr" install
60 endef
62 $(eval $(generic-package))