1 ################################################################################
5 ################################################################################
8 CPPCMS_SOURCE
= cppcms-
$(CPPCMS_VERSION
).
tar.bz2
9 CPPCMS_LICENSE
= LGPLv3
10 CPPCMS_LICENSE_FILES
= COPYING.TXT
11 CPPCMS_SITE
= http
://downloads.sourceforge.net
/project
/cppcms
/cppcms
/$(CPPCMS_VERSION
)
12 CPPCMS_INSTALL_STAGING
= YES
14 CPPCMS_DEPENDENCIES
= zlib pcre libgcrypt
16 ifeq ($(BR2_PACKAGE_CPPCMS_ICU
),y
)
17 CPPCMS_CONF_OPTS
+= -DDISABLE_ICONV
=ON
18 CPPCMS_DEPENDENCIES
+= icu
21 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC
),y
)
22 # posix backend needs monetary.h which isn't available on uClibc
23 CPPCMS_CONF_OPTS
+= -DDISABLE_POSIX_LOCALE
=on
26 # We copy cppcms_tmpl_cc from staging to host because this file can be
27 # needed for compiling packages using cppcms. And it is not worth
28 # creating a host package just for a python script.
29 define CPPCMS_INSTALL_HOST_TOOLS
30 cp
$(STAGING_DIR
)/usr
/bin
/cppcms_tmpl_cc
$(HOST_DIR
)/usr
/bin
/cppcms_tmpl_cc
32 CPPCMS_POST_INSTALL_STAGING_HOOKS
+= CPPCMS_INSTALL_HOST_TOOLS
34 $(eval
$(cmake-package
))