python: make hashlib and readline modules really optional
[buildroot-gz.git] / package / fbterm / fbterm.mk
blobbe3cbe24fdf3242c7a92d96265c024901fa1d6b5
1 ################################################################################
3 # fbterm
5 ################################################################################
7 FBTERM_VERSION = 1.7.0
8 FBTERM_SITE = https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/fbterm
9 FBTERM_LICENSE = GPLv2+
10 FBTERM_LICENSE_FILES = COPYING
11 FBTERM_DEPENDENCIES = fontconfig liberation
13 ifeq ($(BR2_STATIC_LIBS)$(BR2_TOOLCHAIN_HAS_THREADS),yy)
14 # fontconfig uses pthreads if available, but fbterm forgets to link
15 # with it breaking static builds
16 FBTERM_CONF_ENV += LIBS='-lpthread'
17 endif
19 ifeq ($(BR2_PACKAGE_GPM),y)
20 FBTERM_DEPENDENCIES += gpm
21 FBTERM_CONF_OPTS += --enable-gpm
22 else
23 FBTERM_CONF_OPTS += --disable-gpm
24 endif
26 $(eval $(autotools-package))