python: make hashlib and readline modules really optional
[buildroot-gz.git] / package / iodine / iodine.mk
blob711d709c1d8ad4209791c75ff0bed690e1e4f0d5
1 ################################################################################
3 # iodine
5 ################################################################################
7 IODINE_VERSION = 0.7.0
8 IODINE_SITE = http://code.kryo.se/iodine
9 IODINE_DEPENDENCIES = zlib
10 IODINE_LICENSE = MIT
11 IODINE_LICENSE_FILES = README
13 IODINE_CFLAGS = $(TARGET_CFLAGS)
15 # iodine contains a local implementation of daemon(3) for older
16 # systems, unless __GLIBC__ is defined. Musl does provide it, but
17 # unlike uClibc it doesn't define __GLIBC__. Work around it by
18 # pretending to be glibc as we otherwise end up with symbol conflicts.
19 ifeq ($(BR2_TOOLCHAIN_USES_MUSL),y)
20 IODINE_CFLAGS += -D__GLIBC__
21 endif
23 define IODINE_BUILD_CMDS
24 $(TARGET_CONFIGURE_OPTS) CFLAGS="$(IODINE_CFLAGS)" \
25 $(MAKE) ARCH=$(BR2_ARCH) -C $(@D)
26 endef
28 define IODINE_INSTALL_TARGET_CMDS
29 $(TARGET_CONFIGURE_OPTS) $(MAKE) -C $(@D) install DESTDIR="$(TARGET_DIR)" prefix=/usr
30 endef
32 $(eval $(generic-package))