1 ################################################################################
5 ################################################################################
7 # Debian start-stop-daemon is part of dpkg. Since start-stop-daemon is the only
8 # interesting tool in it, we call the buildroot package start-stop-daemon.
10 START_STOP_DAEMON_VERSION
= 1.18.10
11 START_STOP_DAEMON_SOURCE
= dpkg_
$(START_STOP_DAEMON_VERSION
).
tar.xz
12 START_STOP_DAEMON_SITE
= http
://snapshot.debian.org
/archive
/debian
/20160731T221931Z
/pool
/main
/d
/dpkg
13 START_STOP_DAEMON_CONF_OPTS
= \
15 --disable-update-alternatives \
16 --disable-install-info \
18 START_STOP_DAEMON_CONF_ENV
= \
20 dpkg_cv_c99_snprintf
=yes \
22 START_STOP_DAEMON_DEPENDENCIES
= host-pkgconf \
23 $(if
$(BR2_PACKAGE_BUSYBOX
),busybox
)
24 # Patching m4/dpkg-arch.m4
25 START_STOP_DAEMON_AUTORECONF
= YES
26 START_STOP_DAEMON_LICENSE
= GPLv2
+
27 START_STOP_DAEMON_LICENSE_FILES
= COPYING
29 define START_STOP_DAEMON_BUILD_CMDS
30 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
)/lib
/compat
31 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
)/utils
34 define START_STOP_DAEMON_INSTALL_TARGET_CMDS
35 $(INSTALL
) -m
0755 -D
$(@D
)/utils
/start-stop-daemon \
36 $(TARGET_DIR
)/sbin
/start-stop-daemon
39 $(eval
$(autotools-package
))