uboot-tools: add patch to fix linking with libubootenv
[buildroot-gz.git] / package / jamvm / jamvm.mk
blobb1520ada498143cd2b0f872b0c8ddbf4fe0657e7
1 ################################################################################
3 # jamvm
5 ################################################################################
7 JAMVM_VERSION = 2.0.0
8 JAMVM_SITE = http://downloads.sourceforge.net/project/jamvm/jamvm/JamVM%20$(JAMVM_VERSION)
9 JAMVM_LICENSE = GPLv2+
10 JAMVM_LICENSE_FILES = COPYING
11 JAMVM_DEPENDENCIES = zlib classpath
12 # int inlining seems to crash jamvm, don't build shared version of internal lib
13 JAMVM_CONF_OPTS = \
14 --with-classpath-install-dir=/usr \
15 --disable-int-inlining \
16 --disable-shared \
17 --without-pic
19 # jamvm has ARM assembly code that cannot be compiled in Thumb2 mode,
20 # so we must force traditional ARM mode.
21 ifeq ($(BR2_arm),y)
22 JAMVM_CONF_ENV = CFLAGS="$(TARGET_CFLAGS) -marm"
23 endif
25 $(eval $(autotools-package))