uboot-tools: add patch to fix linking with libubootenv
[buildroot-gz.git] / package / tremor / tremor.mk
blob97b0ce36e4a3884a0500812939fb68507c1dc85b
1 ################################################################################
3 # tremor
5 ################################################################################
7 TREMOR_SITE = http://svn.xiph.org/trunk/Tremor
8 TREMOR_SITE_METHOD = svn
9 TREMOR_VERSION = 19427
10 TREMOR_LICENSE = BSD-3c
11 TREMOR_LICENSE_FILES = COPYING
13 TREMOR_AUTORECONF = YES
14 TREMOR_INSTALL_STAGING = YES
15 TREMOR_DEPENDENCIES = libogg
17 # tremor has ARM assembly code that cannot be compiled in Thumb2 mode,
18 # so we must force the traditional ARM mode.
19 ifeq ($(BR2_arm),y)
20 TREMOR_CONF_ENV = \
21 CFLAGS="$(TARGET_CFLAGS) -marm"
22 endif
24 $(eval $(autotools-package))