1 ################################################################################
5 ################################################################################
8 GIT_SOURCE
= git-
$(GIT_VERSION
).
tar.xz
9 GIT_SITE
= https
://www.kernel.org
/pub
/software
/scm
/git
10 GIT_LICENSE
= GPLv2 LGPLv2.1
+
11 GIT_LICENSE_FILES
= COPYING LGPL-2.1
12 GIT_DEPENDENCIES
= zlib host-gettext
14 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
15 GIT_DEPENDENCIES
+= openssl
16 GIT_CONF_OPTS
+= --with-openssl
17 GIT_CONF_ENV_LIBS
+= $(if
$(BR2_STATIC_LIBS
),-lz
)
19 GIT_CONF_OPTS
+= --without-openssl
22 ifeq ($(BR2_PACKAGE_PERL
),y
)
23 GIT_DEPENDENCIES
+= perl
24 GIT_CONF_OPTS
+= --with-libpcre
26 GIT_CONF_OPTS
+= --without-libpcre
29 ifeq ($(BR2_PACKAGE_CURL
),y
)
30 GIT_DEPENDENCIES
+= libcurl
31 GIT_CONF_OPTS
+= --with-curl
33 GIT_CONF_OPTS
+= --without-curl
36 ifeq ($(BR2_PACKAGE_EXPAT
),y
)
37 GIT_DEPENDENCIES
+= expat
38 GIT_CONF_OPTS
+= --with-expat
40 GIT_CONF_OPTS
+= --without-expat
43 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
44 GIT_DEPENDENCIES
+= libiconv
45 GIT_CONF_ENV_LIBS
+= -liconv
46 GIT_CONF_OPTS
+= --with-iconv
=/usr
/lib
48 GIT_CONF_OPTS
+= --without-iconv
51 ifeq ($(BR2_PACKAGE_TCL
),y
)
52 GIT_DEPENDENCIES
+= tcl
53 GIT_CONF_OPTS
+= --with-tcltk
55 GIT_CONF_OPTS
+= --without-tcltk
58 # assume yes for these tests, configure will bail out otherwise
59 # saying error: cannot run test program while cross compiling
61 ac_cv_fread_reads_directories
=yes \
62 ac_cv_snprintf_returns_bogus
=yes LIBS
='$(GIT_CONF_ENV_LIBS)'
64 $(eval
$(autotools-package
))