1 ################################################################################
5 ################################################################################
7 AVRDUDE_VERSION
= ad04c429a90f4c34f000ea4ae11db2705915a31f
8 AVRDUDE_SITE
= $(call github
,kcuzner
,avrdude
,$(AVRDUDE_VERSION
))
9 AVRDUDE_LICENSE
= GPLv2
+
10 AVRDUDE_LICENSE_FILES
= avrdude
/COPYING
11 AVRDUDE_SUBDIR
= avrdude
12 # Sources coming from git, without generated configure and Makefile.in
14 AVRDUDE_AUTORECONF
= YES
15 AVRDUDE_DEPENDENCIES
= elfutils libusb libusb-compat ncurses \
17 AVRDUDE_LICENSE
= GPLv2
+
18 AVRDUDE_LICENSE_FILES
= avrdude
/COPYING
20 ifeq ($(BR2_PACKAGE_LIBFTDI1
),y
)
21 AVRDUDE_DEPENDENCIES
+= libftdi1
22 else ifeq ($(BR2_PACKAGE_LIBFTDI
),y
)
23 AVRDUDE_DEPENDENCIES
+= libftdi
26 # if /etc/avrdude.conf exists, the installation process creates a
27 # backup file, which we do not want in the context of Buildroot.
28 define AVRDUDE_REMOVE_BACKUP_FILE
29 $(RM
) -f
$(TARGET_DIR
)/etc
/avrdude.conf.bak
32 AVRDUDE_POST_INSTALL_TARGET_HOOKS
+= AVRDUDE_REMOVE_BACKUP_FILE
34 $(eval
$(autotools-package
))