1 ################################################################################
5 ################################################################################
8 BASH_SITE
= $(BR2_GNU_MIRROR
)/bash
9 # Build after since bash is better than busybox shells
10 BASH_DEPENDENCIES
= ncurses readline host-bison \
11 $(if
$(BR2_PACKAGE_BUSYBOX
),busybox
)
12 BASH_CONF_OPTS
= --with-installed-readline
14 BASH_LICENSE_FILES
= COPYING
17 ac_cv_rl_prefix
="$(STAGING_DIR)" \
18 ac_cv_rl_version
="$(READLINE_VERSION)" \
19 bash_cv_getcwd_malloc
=yes \
20 bash_cv_job_control_missing
=present \
21 bash_cv_sys_named_pipes
=present \
22 bash_cv_func_sigsetjmp
=present \
23 bash_cv_printf_a_format
=yes
25 # The static build needs some trickery
26 ifeq ($(BR2_STATIC_LIBS
),y
)
27 BASH_CONF_OPTS
+= --enable-static-link
--without-bash-malloc
28 # bash wants to redefine the getenv() function. To check whether this is
29 # possible, AC_TRY_RUN is used which is not possible in
31 # On uClibc, redefining getenv is not possible; on glibc and musl it is.
33 # http://lists.gnu.org/archive/html/bug-bash/2012-03/msg00052.html
34 ifeq ($(BR2_TOOLCHAIN_USES_UCLIBC
),y
)
35 BASH_CONF_ENV
+= bash_cv_getenv_redef
=no
37 BASH_CONF_ENV
+= bash_cv_getenv_redef
=yes
41 # Make /bin/sh -> bash (no other shell, better than busybox shells)
42 define BASH_INSTALL_TARGET_CMDS
43 $(TARGET_MAKE_ENV
) $(MAKE
) -C
$(@D
) \
44 DESTDIR
=$(TARGET_DIR
) exec_prefix=/ install
45 rm -f
$(TARGET_DIR
)/bin
/bashbug
48 $(eval
$(autotools-package
))