1 ################################################################################
5 ################################################################################
7 # Since BerkeleyDB version 6 and above are licensed under the Affero
8 # GPL (AGPL), we want to keep this 'bdb' package at version 5.x to
9 # avoid licensing issues.
10 # BerkeleyDB version 6 or above should be provided by a dedicated
12 BERKELEYDB_VERSION
= 5.3.28
13 BERKELEYDB_SITE
= http
://download.oracle.com
/berkeley-db
14 BERKELEYDB_SOURCE
= db-
$(BERKELEYDB_VERSION
).NC.
tar.gz
15 BERKELEYDB_SUBDIR
= build_unix
16 BERKELEYDB_LICENSE
= BerkeleyDB License
17 BERKELEYDB_LICENSE_FILES
= LICENSE
18 BERKELEYDB_INSTALL_STAGING
= YES
19 BERKELEYDB_BINARIES
= db_archive db_checkpoint db_deadlock db_dump \
20 db_hotbackup db_load db_log_verify db_printlog db_recover db_replicate \
21 db_stat db_tuner db_upgrade db_verify
23 # Internal error, aborting at dw2gencfi.c:214 in emit_expr_encoded
24 # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=79509
25 ifeq ($(BR2_m68k_cf
),y
)
26 BERKELEYDB_CONF_ENV
+= CXXFLAGS
="$(TARGET_CXXFLAGS) -fno-dwarf2-cfi-asm"
29 # build directory can't be the directory where configure are there, so..
30 define BERKELEYDB_CONFIGURE_CMDS
31 (cd
$(@D
)/build_unix
; rm -rf config.cache
; \
32 $(TARGET_CONFIGURE_OPTS
) \
33 $(TARGET_CONFIGURE_ARGS
) \
34 $(BERKELEYDB_CONF_ENV
) \
35 ..
/dist/configure
$(QUIET
) \
36 --target
=$(GNU_TARGET_NAME
) \
37 --host
=$(GNU_TARGET_NAME
) \
38 --build
=$(GNU_HOST_NAME
) \
43 $(if
$(BR2_INSTALL_LIBSTDCPP
),--enable-cxx
,--disable-cxx
) \
46 $(if
$(BR2_PACKAGE_BERKELEYDB_COMPAT185
),--enable-compat185
,--disable-compat185
) \
47 $(SHARED_STATIC_LIBS_OPTS
) \
50 $(if
$(BR2_TOOLCHAIN_HAS_THREADS
),--enable-mutexsupport
,--disable-mutexsupport
) \
54 ifneq ($(BR2_PACKAGE_BERKELEYDB_TOOLS
),y
)
56 define BERKELEYDB_REMOVE_TOOLS
57 rm -f
$(addprefix $(TARGET_DIR
)/usr
/bin
/, $(BERKELEYDB_BINARIES
))
60 BERKELEYDB_POST_INSTALL_TARGET_HOOKS
+= BERKELEYDB_REMOVE_TOOLS
64 define BERKELEYDB_REMOVE_DOCS
65 rm -rf
$(TARGET_DIR
)/usr
/docs
68 BERKELEYDB_POST_INSTALL_TARGET_HOOKS
+= BERKELEYDB_REMOVE_DOCS
70 $(eval
$(autotools-package
))