python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / cache-calibrator / cache-calibrator.mk
blobd0620655c7ea53b5b6d3d9f2a45f54370d88c788
1 ################################################################################
3 # cache-calibrator
5 ################################################################################
7 CACHE_CALIBRATOR_SOURCE = calibrator.c
8 CACHE_CALIBRATOR_SITE = http://homepages.cwi.nl/~manegold/Calibrator/src
9 CACHE_CALIBRATOR_LICENSE = Cache calibrator license
10 CACHE_CALIBRATOR_LICENSE_FILES = calibrator.c
12 define CACHE_CALIBRATOR_EXTRACT_CMDS
13 cp $(DL_DIR)/$(CACHE_CALIBRATOR_SOURCE) $(@D)
14 endef
16 define CACHE_CALIBRATOR_BUILD_CMDS
17 $(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_LDFLAGS) $(@D)/calibrator.c -o $(@D)/cache_calibrator -lm
18 endef
20 define CACHE_CALIBRATOR_INSTALL_TARGET_CMDS
21 $(INSTALL) -D -m 0755 $(@D)/cache_calibrator $(TARGET_DIR)/usr/bin/cache_calibrator
22 endef
24 $(eval $(generic-package))