python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / cc-tool / cc-tool.mk
blobd8df0415c09c96a21719382b07849a14bf377fc1
1 ################################################################################
3 # cc-tool
5 ################################################################################
7 CC_TOOL_VERSION = 0.26
8 CC_TOOL_SITE = http://downloads.sourceforge.net/project/cctool
9 CC_TOOL_SOURCE = cc-tool-$(CC_TOOL_VERSION)-src.tgz
10 CC_TOOL_LICENSE = GPLv2
11 CC_TOOL_LICENSE_FILES = COPYING
12 CC_TOOL_DEPENDENCIES = boost libusb
14 # we're patching boost.m4
15 CC_TOOL_AUTORECONF = YES
17 # Configure script "discovers" boost in /usr/local if not given explicitly
18 CC_TOOL_CONF_OPTS = --with-boost=$(STAGING_DIR)/usr
20 # Help boost.m4 find the Boost Regex library, which needs the pthread
21 # library, but isn't detected using a modern (pkg-config) mechanism.
22 ifeq ($(BR2_STATIC_LIBS),y)
23 CC_TOOL_CONF_ENV += LIBS="-lpthread"
24 endif
26 $(eval $(autotools-package))