python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / cvs / cvs.mk
blob6f28b4dbec8d6e83a0ba536acf0719f5f139b546
1 ################################################################################
3 # cvs
5 ################################################################################
7 CVS_VERSION = 1.12.13
8 CVS_SOURCE = cvs_$(CVS_VERSION).orig.tar.gz
9 CVS_PATCH = cvs_$(CVS_VERSION)-12+squeeze1.diff.gz
10 CVS_SITE = http://snapshot.debian.org/archive/debian/20141023T043132Z/pool/main/c/cvs
11 CVS_DEPENDENCIES = ncurses
13 CVS_CONF_ENV = cvs_cv_func_printf_ptr=yes
15 CVS_CONFIGURE_ARGS = --disable-old-info-format-support
16 ifeq ($(BR2_PACKAGE_CVS_SERVER),y)
17 CVS_CONFIGURE_ARGS += --enable-server
18 else
19 CVS_CONFIGURE_ARGS += --disable-server
20 endif
21 ifeq ($(BR2_PACKAGE_ZLIB),y)
22 CVS_CONFIGURE_ARGS += --with-external-zlib
23 endif
25 CVS_CONF_OPTS = $(CVS_CONFIGURE_ARGS)
27 define CVS_BZIP_UNPACK
28 $(BZCAT) $(@D)/cvs-$(CVS_VERSION).tar.bz2 | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
29 rm -f $(@D)/cvs-$(CVS_VERSION).tar.bz2
30 endef
32 CVS_POST_PATCH_HOOKS += CVS_BZIP_UNPACK
34 ifneq ($(CVS_PATCH),)
35 define CVS_DEBIAN_PATCHES
36 if [ -d $(@D)/debian/patches ]; then \
37 (cd $(@D)/debian/patches && for i in *; \
38 do $(SED) 's,^\+\+\+ .*cvs-$(CVS_VERSION)/,+++ cvs-$(CVS_VERSION)/,' $$i; \
39 done; \
40 ); \
41 $(APPLY_PATCHES) $(@D) $(@D)/debian/patches \*; \
43 endef
44 endif
46 CVS_POST_PATCH_HOOKS += CVS_DEBIAN_PATCHES
48 define CVS_INSTALL_TARGET_CMDS
49 $(INSTALL) -D $(@D)/src/cvs $(TARGET_DIR)/usr/bin/cvs
50 endef
52 $(eval $(autotools-package))