1 ################################################################################
5 ################################################################################
7 DIRECTFB_VERSION_MAJOR
= 1.7
8 DIRECTFB_VERSION
= $(DIRECTFB_VERSION_MAJOR
).7
9 DIRECTFB_SITE
= http
://www.directfb.org
/downloads
/Core
/DirectFB-
$(DIRECTFB_VERSION_MAJOR
)
10 DIRECTFB_SOURCE
= DirectFB-
$(DIRECTFB_VERSION
).
tar.gz
11 DIRECTFB_LICENSE
= LGPLv2.1
+
12 DIRECTFB_LICENSE_FILES
= COPYING
13 DIRECTFB_INSTALL_STAGING
= YES
14 DIRECTFB_AUTORECONF
= YES
16 DIRECTFB_CONF_OPTS
= \
23 --disable-video4linux \
24 --disable-video4linux2 \
28 ifeq ($(BR2_STATIC_LIBS
),y
)
29 DIRECTFB_CONF_OPTS
+= --disable-dynload
32 DIRECTFB_CONFIG_SCRIPTS
= directfb-config
34 DIRECTFB_DEPENDENCIES
= freetype zlib
36 ifeq ($(BR2_PACKAGE_DIRECTFB_MULTI
),y
)
37 DIRECTFB_CONF_OPTS
+= --enable-multi
--enable-multi-kernel
38 DIRECTFB_DEPENDENCIES
+= linux-fusion
40 DIRECTFB_CONF_OPTS
+= --disable-multi
--disable-multi-kernel
43 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG_SUPPORT
),y
)
44 DIRECTFB_CONF_OPTS
+= --enable-debug-support
45 ifeq ($(BR2_PACKAGE_DIRECTFB_DEBUG
),y
)
46 DIRECTFB_CONF_OPTS
+= --enable-debug
49 DIRECTFB_CONF_OPTS
+= --disable-debug-support
52 ifeq ($(BR2_PACKAGE_DIRECTFB_TRACE
),y
)
53 DIRECTFB_CONF_OPTS
+= --enable-trace
56 ifeq ($(BR2_PACKAGE_DIRECTFB_DIVINE
),y
)
57 DIRECTFB_CONF_OPTS
+= --enable-divine
59 DIRECTFB_CONF_OPTS
+= --disable-divine
62 ifeq ($(BR2_PACKAGE_DIRECTFB_SAWMAN
),y
)
63 DIRECTFB_CONF_OPTS
+= --enable-sawman
65 DIRECTFB_CONF_OPTS
+= --disable-sawman
69 $(if
$(BR2_PACKAGE_DIRECTFB_ATI128
),ati128
) \
70 $(if
$(BR2_PACKAGE_DIRECTFB_CYBER5K
),cyber5k
) \
71 $(if
$(BR2_PACKAGE_DIRECTFB_MATROX
),matrox
) \
72 $(if
$(BR2_PACKAGE_DIRECTFB_PXA3XX
),pxa3xx
) \
73 $(if
$(BR2_PACKAGE_DIRECTFB_I830
),i830
) \
74 $(if
$(BR2_PACKAGE_DIRECTFB_EP9X
),ep9x
)
76 ifeq ($(strip $(DIRECTFB_GFX
)),)
77 DIRECTFB_CONF_OPTS
+= --with-gfxdrivers
=none
79 DIRECTFB_CONF_OPTS
+= \
80 --with-gfxdrivers
=$(subst $(space
),$(comma
),$(strip $(DIRECTFB_GFX
)))
84 $(if
$(BR2_PACKAGE_DIRECTFB_LINUXINPUT
),linuxinput
) \
85 $(if
$(BR2_PACKAGE_DIRECTFB_KEYBOARD
),keyboard
) \
86 $(if
$(BR2_PACKAGE_DIRECTFB_PS2MOUSE
),ps2mouse
) \
87 $(if
$(BR2_PACKAGE_DIRECTFB_SERIALMOUSE
),serialmouse
) \
88 $(if
$(BR2_PACKAGE_DIRECTFB_TSLIB
),tslib
)
90 ifeq ($(BR2_PACKAGE_DIRECTFB_TSLIB
),y
)
91 DIRECTFB_DEPENDENCIES
+= tslib
94 ifeq ($(strip $(DIRECTFB_INPUT
)),)
95 DIRECTFB_CONF_OPTS
+= --with-inputdrivers
=none
97 DIRECTFB_CONF_OPTS
+= \
98 --with-inputdrivers
=$(subst $(space
),$(comma
),$(strip $(DIRECTFB_INPUT
)))
101 ifeq ($(BR2_PACKAGE_DIRECTFB_GIF
),y
)
102 DIRECTFB_CONF_OPTS
+= --enable-gif
104 DIRECTFB_CONF_OPTS
+= --disable-gif
107 ifeq ($(BR2_PACKAGE_DIRECTFB_TIFF
),y
)
108 DIRECTFB_CONF_OPTS
+= --enable-tiff
109 DIRECTFB_DEPENDENCIES
+= tiff
111 DIRECTFB_CONF_OPTS
+= --disable-tiff
114 ifeq ($(BR2_PACKAGE_DIRECTFB_PNG
),y
)
115 DIRECTFB_CONF_OPTS
+= --enable-png
116 DIRECTFB_DEPENDENCIES
+= libpng
117 DIRECTFB_CONF_ENV
+= ac_cv_path_LIBPNG_CONFIG
=$(STAGING_DIR
)/usr
/bin
/libpng-config
119 DIRECTFB_CONF_OPTS
+= --disable-png
122 ifeq ($(BR2_PACKAGE_DIRECTFB_JPEG
),y
)
123 DIRECTFB_CONF_OPTS
+= --enable-jpeg
124 DIRECTFB_DEPENDENCIES
+= jpeg
126 DIRECTFB_CONF_OPTS
+= --disable-jpeg
129 ifeq ($(BR2_PACKAGE_DIRECTFB_SVG
),y
)
130 DIRECTFB_CONF_OPTS
+= --enable-svg
131 # needs some help to find cairo includes
132 DIRECTFB_CONF_ENV
+= CPPFLAGS
="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/cairo"
133 DIRECTFB_DEPENDENCIES
+= libsvg-cairo
135 DIRECTFB_CONF_OPTS
+= --disable-svg
138 ifeq ($(BR2_PACKAGE_DIRECTFB_IMLIB2
),y
)
139 DIRECTFB_CONF_OPTS
+= --enable-imlib2
140 DIRECTFB_DEPENDENCIES
+= imlib2
141 DIRECTFB_CONF_ENV
+= ac_cv_path_IMLIB2_CONFIG
=$(STAGING_DIR
)/usr
/bin
/imlib2-config
143 DIRECTFB_CONF_OPTS
+= --disable-imlib2
146 ifeq ($(BR2_PACKAGE_DIRECTFB_DITHER_RGB16
),y
)
147 DIRECTFB_CONF_OPTS
+= --with-dither-rgb16
=advanced
149 DIRECTFB_CONF_OPTS
+= --with-dither-rgb16
=none
152 ifeq ($(BR2_PACKAGE_DIRECTFB_TESTS
),y
)
153 DIRECTFB_CONF_OPTS
+= --with-tests
156 HOST_DIRECTFB_DEPENDENCIES
= host-pkgconf host-libpng
157 HOST_DIRECTFB_CONF_OPTS
= \
160 --with-gfxdrivers
=none \
161 --with-inputdrivers
=none
163 HOST_DIRECTFB_BUILD_CMDS
= \
164 $(HOST_MAKE_ENV
) $(MAKE
) -C
$(@D
)/tools directfb-csource
166 HOST_DIRECTFB_INSTALL_CMDS
= \
167 $(INSTALL
) -m
0755 $(@D
)/tools
/directfb-csource
$(HOST_DIR
)/usr
/bin
169 $(eval
$(autotools-package
))
170 $(eval
$(host-autotools-package
))
172 # directfb-csource for the host
173 DIRECTFB_HOST_BINARY
= $(HOST_DIR
)/usr
/bin
/directfb-csource