1 ################################################################################
5 ################################################################################
8 EVEMU_SITE
= http
://www.freedesktop.org
/software
/evemu
9 EVEMU_SOURCE
= evemu-
$(EVEMU_VERSION
).
tar.xz
10 EVEMU_LICENSE
= LGPLv3
(library
), GPLv3
(tools
)
11 EVEMU_LICENSE_FILES
= COPYING
13 # asciidoc used to generate manpages, which we don't need, and if it's
14 # present on the build host, it ends getting called with our host-python
15 # which doesn't have all the needed modules enabled, breaking the build
16 EVEMU_CONF_ENV
= ac_cv_path_ASCIIDOC
=""
18 # disable tests generation because of C++ dependency
19 EVEMU_CONF_OPTS
+= --disable-tests
21 # Uses PKG_CHECK_MODULES() in configure.ac
22 EVEMU_DEPENDENCIES
= host-pkgconf libevdev
24 # Check for target python
25 ifeq ($(BR2_PACKAGE_PYTHON
)$(BR2_PACKAGE_PYTHON3
),y
)
26 EVEMU_CONF_OPTS
+= --enable-python-bindings
27 EVEMU_DEPENDENCIES
+= $(if
$(BR2_PACKAGE_PYTHON3
),python3
,python
)
29 EVEMU_CONF_OPTS
+= --disable-python-bindings
32 $(eval
$(autotools-package
))