python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / fcgiwrap / fcgiwrap.mk
blobdd74c1ef72e6e3754924c37f5cb900ce2a0aa18c
1 ################################################################################
3 # fcgiwrap
5 ################################################################################
7 FCGIWRAP_VERSION = 99c942c90063c73734e56bacaa65f947772d9186
8 FCGIWRAP_SITE = $(call github,gnosek,fcgiwrap,$(FCGIWRAP_VERSION))
9 FCGIWRAP_DEPENDENCIES = host-pkgconf libfcgi
10 FCGIWRAP_LICENSE = MIT
11 FCGIWRAP_LICENSE_FILES = COPYING
12 FCGIWRAP_AUTORECONF = YES
14 ifeq ($(BR2_PACKAGE_SYSTEMD),y)
15 FCGIWRAP_DEPENDENCIES += systemd
16 FCGIWRAP_CONF_OPTS += --with-systemd
17 else
18 FCGIWRAP_CONF_OPTS += --without-systemd
19 endif
21 # libfcgi needs libm and fcgiwrap does not use libtool or pkgconf to
22 # detect libfcgi, so we need to add -lm explicitely when using static
23 # libs.
24 ifeq ($(BR2_STATIC_LIBS),y)
25 FCGIWRAP_CONF_OPTS += LIBS=-lm
26 endif
28 # fcgiwrap uses Autoconf, but not Automake, so we need to provide
29 # these to make.
30 FCGIWRAP_MAKE_ENV = $(TARGET_CONFIGURE_OPTS)
32 $(eval $(autotools-package))