1 ################################################################################
5 ################################################################################
8 FLTK_SOURCE
= fltk-
$(FLTK_VERSION
)-source.
tar.gz
9 FLTK_SITE
= http
://fltk.org
/pub
/fltk
/$(FLTK_VERSION
)
10 FLTK_INSTALL_STAGING
= YES
11 # We force --libdir=/usr/lib, because by default, it is set to
12 # ${exec_prefix}/lib, which doesn't match the condition used by the
13 # fltk build system to decide whether it should pass a -rpath,/usr/lib
14 # or not. Since this rpath breaks the build, we want the fltk build
15 # system to not pass it, which requires having --libdir set to
17 FLTK_CONF_OPTS
= --enable-threads
--with-x
--disable-gl \
18 --disable-localjpeg
--disable-localpng
--disable-localzlib \
20 FLTK_DEPENDENCIES
= jpeg libpng xlib_libX11 xlib_libXext xlib_libXt
21 FLTK_CONFIG_SCRIPTS
= fltk-config
22 FLTK_LICENSE
= LGPLv2 with exceptions
23 FLTK_LICENSE_FILES
= COPYING
25 ifeq ($(BR2_PACKAGE_CAIRO
),y
)
26 FLTK_CONF_OPTS
+= --enable-cairo
27 FLTK_DEPENDENCIES
+= cairo
30 ifeq ($(BR2_PACKAGE_XLIB_LIBXCURSOR
),y
)
31 FLTK_DEPENDENCIES
+= xlib_libXcursor
32 FLTK_CONF_OPTS
+= --enable-xcursor
34 FLTK_CONF_OPTS
+= --disable-xcursor
37 ifeq ($(BR2_PACKAGE_XLIB_LIBXFIXES
),y
)
38 FLTK_DEPENDENCIES
+= xlib_libXfixes
39 FLTK_CONF_OPTS
+= --enable-xfixes
41 FLTK_CONF_OPTS
+= --disable-xfixes
44 ifeq ($(BR2_PACKAGE_XLIB_LIBXFT
),y
)
45 FLTK_CONF_ENV
+= ac_cv_path_FTCONFIG
=$(STAGING_DIR
)/usr
/bin
/freetype-config
46 FLTK_DEPENDENCIES
+= xlib_libXft
48 FLTK_CONF_OPTS
+= --disable-xft
51 ifeq ($(BR2_PACKAGE_XLIB_LIBXINERAMA
),y
)
52 FLTK_DEPENDENCIES
+= xlib_libXinerama
54 FLTK_CONF_OPTS
+= --disable-xinerama
57 $(eval
$(autotools-package
))