python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / getent / getent.mk
blobed249e8d45695b87ffcf7f53c4f004900239974b
1 ################################################################################
3 # getent
5 ################################################################################
7 GETENT_LICENSE = LGPLv2.1+
9 # For glibc toolchains, we use the getent program built/installed by
10 # the C library. For other toolchains, we use the wrapper script
11 # included in this package.
12 ifeq ($(BR2_TOOLCHAIN_USES_GLIBC),y)
13 # Sourcery toolchains install it in sysroot/usr/lib/bin
14 # Buildroot toolchains install it in sysroot/usr/bin
15 GETENT_LOCATION = $(firstword $(wildcard \
16 $(STAGING_DIR)/usr/bin/getent \
17 $(STAGING_DIR)/usr/lib/bin/getent))
18 else
19 GETENT_LOCATION = package/getent/getent
20 endif
22 define GETENT_INSTALL_TARGET_CMDS
23 $(INSTALL) -D -m 0755 $(GETENT_LOCATION) $(TARGET_DIR)/usr/bin/getent
24 endef
26 $(eval $(generic-package))