python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / giflib / giflib.mk
blob799ae732262dc8c73aa9da564217c9c64324db60
1 ################################################################################
3 # giflib
5 ################################################################################
7 GIFLIB_VERSION = 5.1.4
8 GIFLIB_SOURCE = giflib-$(GIFLIB_VERSION).tar.bz2
9 GIFLIB_SITE = http://downloads.sourceforge.net/project/giflib
10 GIFLIB_INSTALL_STAGING = YES
11 GIFLIB_LICENSE = MIT
12 GIFLIB_LICENSE_FILES = COPYING
14 GIFLIB_BINS = \
15 gif2epsn gif2ps gif2rgb gif2x11 gifasm gifbg gifbuild gifburst gifclip \
16 gifclrmp gifcolor gifcomb gifcompose gifecho giffiltr giffix gifflip \
17 gifhisto gifinfo gifinter gifinto gifovly gifpos gifrotat \
18 gifrsize gifspnge giftext giftool gifwedge icon2gif raw2gif rgb2gif \
19 text2gif
21 define GIFLIB_BINS_CLEANUP
22 rm -f $(addprefix $(TARGET_DIR)/usr/bin/,$(GIFLIB_BINS))
23 endef
25 GIFLIB_POST_INSTALL_TARGET_HOOKS += GIFLIB_BINS_CLEANUP
27 $(eval $(autotools-package))
28 $(eval $(host-autotools-package))