1 ################################################################################
5 ################################################################################
8 GIT_SOURCE
= git-
$(GIT_VERSION
).
tar.xz
9 GIT_SITE
= https
://www.kernel.org
/pub
/software
/scm
/git
10 GIT_LICENSE
= GPLv2
, LGPLv2.1
+
11 GIT_LICENSE_FILES
= COPYING LGPL-2.1
12 GIT_DEPENDENCIES
= zlib host-gettext
14 ifeq ($(BR2_PACKAGE_GETTEXT
),y
)
15 GIT_DEPENDENCIES
+= gettext
18 ifeq ($(BR2_PACKAGE_OPENSSL
),y
)
19 GIT_DEPENDENCIES
+= openssl
20 GIT_CONF_OPTS
+= --with-openssl
21 GIT_CONF_ENV_LIBS
+= $(if
$(BR2_STATIC_LIBS
),-lz
)
23 GIT_CONF_OPTS
+= --without-openssl
26 ifeq ($(BR2_PACKAGE_PCRE
),y
)
27 GIT_DEPENDENCIES
+= pcre
28 GIT_CONF_OPTS
+= --with-libpcre
30 GIT_CONF_OPTS
+= --without-libpcre
33 ifeq ($(BR2_PACKAGE_LIBCURL
),y
)
34 GIT_DEPENDENCIES
+= libcurl
35 GIT_CONF_OPTS
+= --with-curl
37 ac_cv_prog_curl_config
=$(STAGING_DIR
)/usr
/bin
/$(LIBCURL_CONFIG_SCRIPTS
)
39 GIT_CONF_OPTS
+= --without-curl
42 ifeq ($(BR2_PACKAGE_EXPAT
),y
)
43 GIT_DEPENDENCIES
+= expat
44 GIT_CONF_OPTS
+= --with-expat
46 GIT_CONF_OPTS
+= --without-expat
49 ifeq ($(BR2_PACKAGE_LIBICONV
),y
)
50 GIT_DEPENDENCIES
+= libiconv
51 GIT_CONF_ENV_LIBS
+= -liconv
52 GIT_CONF_OPTS
+= --with-iconv
=/usr
/lib
54 GIT_CONF_OPTS
+= --without-iconv
57 ifeq ($(BR2_PACKAGE_TCL
),y
)
58 GIT_DEPENDENCIES
+= tcl
59 GIT_CONF_OPTS
+= --with-tcltk
61 GIT_CONF_OPTS
+= --without-tcltk
64 # assume yes for these tests, configure will bail out otherwise
65 # saying error: cannot run test program while cross compiling
67 ac_cv_fread_reads_directories
=yes \
68 ac_cv_snprintf_returns_bogus
=yes LIBS
='$(GIT_CONF_ENV_LIBS)'
70 $(eval
$(autotools-package
))