python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / gzip / gzip.mk
blobc4e91b07ccba72768e32e36ca326b8fd672e7eb8
1 ################################################################################
3 # gzip
5 ################################################################################
7 GZIP_VERSION = 1.8
8 GZIP_SOURCE = gzip-$(GZIP_VERSION).tar.xz
9 GZIP_SITE = $(BR2_GNU_MIRROR)/gzip
10 # Some other tools expect it to be in /bin
11 GZIP_CONF_OPTS = --exec-prefix=/
12 # Prefer full gzip over potentially lightweight/slower from busybox
13 GZIP_DEPENDENCIES = $(if $(BR2_PACKAGE_BUSYBOX),busybox)
14 GZIP_LICENSE = GPLv3+
15 GZIP_LICENSE_FILES = COPYING
16 GZIP_CONF_ENV += gl_cv_func_fflush_stdin=yes
17 # configure substitutes $(SHELL) for the shell shebang in scripts like
18 # gzexe. Unfortunately, the same $(SHELL) variable will also be used by
19 # make to run its commands. Fortunately, /bin/sh is always a POSIX shell
20 # on both the target and host systems that we support. Even with this,
21 # the configure check is slightly broken and prints a bogus warning:
22 # "using /bin/sh, even though it may have file descriptor bugs"
23 GZIP_CONF_ENV += ac_cv_path_shell=/bin/sh
25 $(eval $(autotools-package))