python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / htop / htop.mk
blob9451d159fab9217e736c729889dac131519cc92b
1 ################################################################################
3 # htop
5 ################################################################################
7 HTOP_VERSION = 2.0.2
8 HTOP_SITE = http://hisham.hm/htop/releases/$(HTOP_VERSION)
9 HTOP_DEPENDENCIES = ncurses
10 # Prevent htop build system from searching the host paths
11 HTOP_CONF_ENV = HTOP_NCURSES_CONFIG_SCRIPT=$(STAGING_DIR)/usr/bin/ncurses5-config
12 HTOP_LICENSE = GPLv2
13 HTOP_LICENSE_FILES = COPYING
15 ifeq ($(BR2_PACKAGE_NCURSES_WCHAR),y)
16 HTOP_CONF_OPTS += --enable-unicode
17 else
18 HTOP_CONF_OPTS += --disable-unicode
19 endif
21 # ARC uses an old uClibc that needs dladdr() for backtrace support,
22 # which doesn't work for static only scenario, so as a workaround, we
23 # pretend that execinfo.h is not available.
24 ifeq ($(BR2_arc)$(BR2_STATIC_LIBS),yy)
25 HTOP_CONF_ENV += ac_cv_header_execinfo_h=no
26 endif
28 $(eval $(autotools-package))