python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / ibrcommon / ibrcommon.mk
blob4d2d351c8817ef0801d29c2f4e018aeec6f896d0
1 ################################################################################
3 # ibrcommon
5 ################################################################################
7 IBRCOMMON_VERSION = 1.0.1
8 IBRCOMMON_SITE = https://www.ibr.cs.tu-bs.de/projects/ibr-dtn/releases
9 IBRCOMMON_INSTALL_STAGING = YES
10 IBRCOMMON_LICENSE = Apache-2.0
11 IBRCOMMON_LICENSE_FILES = COPYING README
12 IBRCOMMON_DEPENDENCIES = host-pkgconf
14 ifeq ($(BR2_PACKAGE_OPENSSL),y)
15 IBRCOMMON_DEPENDENCIES += openssl
16 IBRCOMMON_CONF_OPTS += --with-openssl
17 else
18 IBRCOMMON_CONF_OPTS += --without-openssl
19 endif
21 ifeq ($(BR2_PACKAGE_LIBNL),y)
22 IBRCOMMON_DEPENDENCIES += libnl
23 IBRCOMMON_CONF_OPTS += --with-lowpan
24 else
25 IBRCOMMON_CONF_OPTS += --without-lowpan
26 endif
28 ifeq ($(BR2_PACKAGE_LIBXML2),y)
29 IBRCOMMON_DEPENDENCIES += libxml2
30 IBRCOMMON_CONF_OPTS += --with-xml
31 else
32 IBRCOMMON_CONF_OPTS += --without-xml
33 endif
35 $(eval $(autotools-package))