python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / ipmitool / ipmitool.mk
blobf4dca736cb3c24f225cee089fa0f775a534f34f8
1 ################################################################################
3 # ipmitool
5 ################################################################################
7 IPMITOOL_VERSION = 1.8.18
8 IPMITOOL_SOURCE = ipmitool-$(IPMITOOL_VERSION).tar.bz2
9 IPMITOOL_SITE = http://downloads.sourceforge.net/project/ipmitool/ipmitool/$(IPMITOOL_VERSION)
10 IPMITOOL_LICENSE = BSD-3c
11 IPMITOOL_LICENSE_FILES = COPYING
13 ifeq ($(BR2_PACKAGE_IPMITOOL_LANPLUS),y)
14 IPMITOOL_DEPENDENCIES += openssl
15 IPMITOOL_CONF_OPTS += --enable-intf-lanplus
16 else
17 IPMITOOL_CONF_OPTS += --disable-intf-lanplus
18 endif
20 ifeq ($(BR2_PACKAGE_IPMITOOL_IPMISHELL),y)
21 IPMITOOL_DEPENDENCIES += ncurses readline
22 IPMITOOL_CONF_OPTS += --enable-ipmishell
23 else
24 IPMITOOL_CONF_OPTS += --disable-ipmishell
25 endif
27 ifeq ($(BR2_PACKAGE_IPMITOOL_IPMIEVD),)
28 define IPMITOOL_REMOVE_IPMIEVD
29 $(RM) -f $(TARGET_DIR)/usr/sbin/ipmievd
30 endef
31 IPMITOOL_POST_INSTALL_TARGET_HOOKS += IPMITOOL_REMOVE_IPMIEVD
32 endif
34 $(eval $(autotools-package))