python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / ipsec-tools / ipsec-tools.mk
blobeb910bc498f42fb81080fc91ea9b140ecaf2ad73
1 ################################################################################
3 # ipsec-tools
5 ################################################################################
7 IPSEC_TOOLS_VERSION = 0.8.2
8 IPSEC_TOOLS_SOURCE = ipsec-tools-$(IPSEC_TOOLS_VERSION).tar.bz2
9 IPSEC_TOOLS_SITE = http://sourceforge.net/projects/ipsec-tools/files/ipsec-tools/$(IPSEC_TOOLS_VERSION)
10 IPSEC_TOOLS_INSTALL_STAGING = YES
11 IPSEC_TOOLS_MAKE = $(MAKE1)
12 IPSEC_TOOLS_DEPENDENCIES = openssl flex host-flex
14 # configure hardcodes -Werror, so override CFLAGS on make invocation
15 IPSEC_TOOLS_MAKE_OPTS = CFLAGS='$(TARGET_CFLAGS)'
17 # openssl uses zlib, so we need to explicitly link with it when static
18 ifeq ($(BR2_STATIC_LIBS),y)
19 IPSEC_TOOLS_CONF_ENV += LIBS=-lz
20 endif
22 IPSEC_TOOLS_CONF_OPTS = \
23 --without-libpam \
24 --disable-gssapi \
25 --with-kernel-headers=$(STAGING_DIR)/usr/include
27 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_ADMINPORT),y)
28 IPSEC_TOOLS_CONF_OPTS += --enable-adminport
29 else
30 IPSEC_TOOLS_CONF_OPTS += --disable-adminport
31 endif
33 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_NATT),y)
34 IPSEC_TOOLS_CONF_OPTS += --enable-natt
35 else
36 IPSEC_TOOLS_CONF_OPTS += --disable-natt
37 endif
39 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_FRAG),y)
40 IPSEC_TOOLS_CONF_OPTS += --enable-frag
41 else
42 IPSEC_TOOLS_CONF_OPTS += --disable-frag
43 endif
45 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_DPD),y)
46 IPSEC_TOOLS_CONF_OPTS += --enable-dpd
47 else
48 IPSEC_TOOLS_CONF_OPTS += --disable-dpd
49 endif
51 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_STATS),y)
52 IPSEC_TOOLS_CONF_OPTS += --enable-stats
53 else
54 IPSEC_TOOLS_CONF_OPTS += --disable-stats
55 endif
57 ifneq ($(BR2_PACKAGE_IPSEC_TOOLS_READLINE),y)
58 IPSEC_TOOLS_CONF_OPTS += --without-readline
59 else
60 IPSEC_TOOLS_DEPENDENCIES += readline
61 endif
63 ifeq ($(BR2_PACKAGE_IPSEC_TOOLS_HYBRID),y)
64 IPSEC_TOOLS_CONF_OPTS += --enable-hybrid
65 else
66 IPSEC_TOOLS_CONF_OPTS += --disable-hybrid
67 endif
69 ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_DISABLE),y)
70 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=no
71 endif
72 ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_ENABLE),y)
73 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=yes
74 endif
75 ifeq ($(BR2_PACKAGE_IPSEC_SECCTX_KERNEL),y)
76 IPSEC_TOOLS_CONF_OPTS += --enable-security-context=kernel
77 endif
79 $(eval $(autotools-package))