python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / libnl / libnl.mk
blobf31a92c206f9edacfae2950097596e91278e1ead
1 ################################################################################
3 # libnl
5 ################################################################################
7 LIBNL_VERSION = 3.2.29
8 LIBNL_SITE = https://github.com/thom311/libnl/releases/download/libnl$(subst .,_,$(LIBNL_VERSION))
9 LIBNL_LICENSE = LGPLv2.1+
10 LIBNL_LICENSE_FILES = COPYING
11 LIBNL_INSTALL_STAGING = YES
12 LIBNL_DEPENDENCIES = host-bison host-flex host-pkgconf
13 # Patching configure.ac
14 LIBNL_AUTORECONF = YES
16 ifeq ($(BR2_PACKAGE_LIBNL_TOOLS),y)
17 LIBNL_CONF_OPTS += --enable-cli
18 else
19 LIBNL_CONF_OPTS += --disable-cli
20 endif
22 ifeq ($(BR2_PACKAGE_CHECK),y)
23 LIBNL_DEPENDENCIES += check
24 LIBNL_CONF_OPTS += --enable-unit-tests
25 else
26 LIBNL_CONF_OPTS += --disable-unit-tests
27 endif
29 $(eval $(autotools-package))