1 ################################################################################
5 ################################################################################
8 LLDPD_SITE
= http
://media.luffy.cx
/files
/lldpd
9 LLDPD_DEPENDENCIES
= host-pkgconf libevent
11 LLDPD_LICENSE_FILES
= README.md
12 # 0002-configure-do-not-check-for-libbsd.patch
13 LLDPD_AUTORECONF
= YES
15 ifeq ($(BR2_PACKAGE_CHECK
),y
)
16 LLDPD_DEPENDENCIES
+= check
19 ifeq ($(BR2_PACKAGE_VALGRIND
),y
)
20 LLDPD_DEPENDENCIES
+= valgrind
23 # Detection of c99 support in configure fails without WCHAR. To enable
24 # automatic detection of c99 support by configure, we need to enable
25 # WCHAR in toolchain. But actually we do not need WCHAR at lldpd
26 # runtime. So requesting WCHAR in toolchain just for automatic detection
27 # will be overkill. To solve this, explicitly -specify c99 here.
28 LLDPD_CONF_ENV
= ac_cv_prog_cc_c99
=-std
=gnu99
32 --without-embedded-libevent \
39 $(if
$(BR2_PACKAGE_LLDPD_CDP
),--enable-cdp
,--disable-cdp
) \
40 $(if
$(BR2_PACKAGE_LLDPD_FDP
),--enable-fdp
,--disable-fdp
) \
41 $(if
$(BR2_PACKAGE_LLDPD_EDP
),--enable-edp
,--disable-edp
) \
42 $(if
$(BR2_PACKAGE_LLDPD_SONMP
),--enable-sonmp
,--disable-sonmp
) \
43 $(if
$(BR2_PACKAGE_LLDPD_LLDPMED
),--enable-lldpmed
,--disable-lldpmed
) \
44 $(if
$(BR2_PACKAGE_LLDPD_DOT1
),--enable-dot1
,--disable-dot1
) \
45 $(if
$(BR2_PACKAGE_LLDPD_DOT3
),--enable-dot3
,--disable-dot3
) \
46 $(if
$(BR2_PACKAGE_LLDPD_CUSTOM_TLV
),--enable-custom
,--disable-custom
)
48 define LLDPD_INSTALL_INIT_SYSV
49 $(INSTALL
) -D
-m
0755 package
/lldpd
/S60lldpd \
50 $(TARGET_DIR
)/etc
/init.d
/S60lldpd
53 $(eval
$(autotools-package
))