1 ################################################################################
5 ################################################################################
7 LTRIS_SITE
= http
://downloads.sourceforge.net
/lgames
/ltris
10 LTRIS_LICENSE_FILES
= COPYING
12 LTRIS_DEPENDENCIES
= sdl
15 SDL_CONFIG
="$(STAGING_DIR)/usr/bin/sdl-config" \
18 ifeq ($(BR2_PACKAGE_LTRIS_AUDIO
),y
)
19 LTRIS_DEPENDENCIES
+= sdl_mixer host-pkgconf
20 LTRIS_CONF_OPTS
+= --enable-sound
21 # configure script does NOT use pkg-config to figure out how to link
22 # with sdl_mixer, breaking static linking as sdl_mixer can use libmad
23 LTRIS_LIBS
+= `$(PKG_CONFIG_HOST_BINARY) --libs SDL_mixer`
25 LTRIS_CONF_OPTS
+= --disable-sound
28 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE
),y
)
29 LTRIS_DEPENDENCIES
+= gettext
33 $(eval
$(autotools-package
))