python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / ltris / ltris.mk
blobbbd270ea133dbc847a53eb1850d95327981f611c
1 ################################################################################
3 # ltris
5 ################################################################################
7 LTRIS_SITE = http://downloads.sourceforge.net/lgames/ltris
8 LTRIS_VERSION = 1.0.19
9 LTRIS_LICENSE = GPLv2+
10 LTRIS_LICENSE_FILES = COPYING
12 LTRIS_DEPENDENCIES = sdl
14 LTRIS_CONF_ENV = \
15 SDL_CONFIG="$(STAGING_DIR)/usr/bin/sdl-config" \
16 LIBS="$(LTRIS_LIBS)"
18 ifeq ($(BR2_PACKAGE_LTRIS_AUDIO),y)
19 LTRIS_DEPENDENCIES += sdl_mixer host-pkgconf
20 LTRIS_CONF_OPTS += --enable-sound
21 # configure script does NOT use pkg-config to figure out how to link
22 # with sdl_mixer, breaking static linking as sdl_mixer can use libmad
23 LTRIS_LIBS += `$(PKG_CONFIG_HOST_BINARY) --libs SDL_mixer`
24 else
25 LTRIS_CONF_OPTS += --disable-sound
26 endif
28 ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
29 LTRIS_DEPENDENCIES += gettext
30 LTRIS_LIBS += -lintl
31 endif
33 $(eval $(autotools-package))