python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / monit / monit.mk
blobf4899c3c0dd11232b64788c349e81bf06d1a3778
1 ################################################################################
3 # monit
5 ################################################################################
7 MONIT_VERSION = 5.20.0
8 MONIT_SITE = http://mmonit.com/monit/dist
9 MONIT_LICENSE = AGPLv3 with OpenSSL exception
10 MONIT_LICENSE_FILES = COPYING
12 # Touching Makefile.am:
13 MONIT_AUTORECONF = YES
15 MONIT_CONF_ENV = \
16 libmonit_cv_setjmp_available=yes \
17 libmonit_cv_vsnprintf_c99_conformant=yes
19 MONIT_CONF_OPTS += \
20 --without-pam \
21 --with-largefiles
23 ifeq ($(BR2_PACKAGE_OPENSSL),y)
24 MONIT_CONF_OPTS += --with-ssl=$(STAGING_DIR)/usr
25 MONIT_DEPENDENCIES += openssl
26 else
27 MONIT_CONF_OPTS += --without-ssl
28 endif
30 ifeq ($(BR2_PACKAGE_ZLIB),y)
31 MONIT_CONF_OPTS += --with-zlib
32 MONIT_DEPENDENCIES += zlib
33 else
34 MONIT_CONF_OPTS += --without-zlib
35 endif
37 $(eval $(autotools-package))