python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / mosh / mosh.mk
blob2cd358b39745b842c0d42af0122a7ff41391946a
1 ################################################################################
3 # mosh
5 ################################################################################
7 MOSH_VERSION = 1.2.6
8 MOSH_SITE = https://mosh.mit.edu
9 MOSH_DEPENDENCIES = zlib ncurses protobuf host-pkgconf
10 MOSH_LICENSE = GPLv3+ with exception
11 MOSH_LICENSE_FILES = COPYING COPYING.iOS
13 ifeq ($(BR2_PACKAGE_OPENSSL),y)
14 MOSH_CONF_OPTS += --with-crypto-library=openssl
15 MOSH_DEPENDENCIES += openssl
16 else
17 MOSH_CONF_OPTS += --with-crypto-library=nettle
18 MOSH_DEPENDENCIES += nettle
19 endif
21 # help the detection of the SSP support: mosh configure.ac doesn't do
22 # a link test, so it doesn't detect when the toolchain doesn't have
23 # libssp.
24 ifeq ($(BR2_TOOLCHAIN_HAS_SSP),)
25 MOSH_CONF_ENV += \
26 ax_cv_check_cflags__Werror___fstack_protector_all=no \
27 ax_cv_check_cxxflags__Werror___fstack_protector_all=no
28 endif
30 $(eval $(autotools-package))