1 ################################################################################
5 ################################################################################
8 NCFTP_SOURCE
= ncftp-
$(NCFTP_VERSION
)-src.
tar.xz
9 NCFTP_SITE
= ftp
://ftp.ncftp.com
/ncftp
10 NCFTP_TARGET_BINS
= ncftp
11 NCFTP_LICENSE
= Clarified Artistic License
12 NCFTP_LICENSE_FILES
= doc
/LICENSE.txt
14 NCFTP_DEPENDENCIES
= host-autoconf
15 NCFTP_CONF_OPTS
= --disable-ccdv
17 # The bundled configure script is generated by autoconf 2.13 and doesn't
18 # detect cross-compilation correctly. Therefore, we have to regenerate it.
19 # We need to pass -I because of the non-standard m4 directory name, and
20 # none of the other autotools are used, so the below is the easiest.
21 define NCFTP_RUN_AUTOCONF
22 (cd
$(@D
); $(HOST_DIR
)/usr
/bin
/autoconf
-I
$(@D
)/autoconf_local
/)
24 NCFTP_PRE_CONFIGURE_HOOKS
+= NCFTP_RUN_AUTOCONF
26 ifeq ($(BR2_PACKAGE_NCFTP_GET
),y
)
27 NCFTP_TARGET_BINS
+= ncftpget
30 ifeq ($(BR2_PACKAGE_NCFTP_PUT
),y
)
31 NCFTP_TARGET_BINS
+= ncftpput
34 ifeq ($(BR2_PACKAGE_NCFTP_LS
),y
)
35 NCFTP_TARGET_BINS
+= ncftpls
38 ifeq ($(BR2_PACKAGE_NCFTP_BATCH
),y
)
39 NCFTP_TARGET_BINS
+= ncftpbatch
40 NCFTP_INSTALL_NCFTP_BATCH
= \
41 ln
-sf
/usr
/bin
/ncftpbatch
$(TARGET_DIR
)/usr
/bin
/ncftpspooler
44 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS
),y
)
45 NCFTP_TARGET_BINS
+= ncftpbookmarks
46 NCFTP_DEPENDENCIES
+= ncurses
49 define NCFTP_INSTALL_TARGET_CMDS
50 $(INSTALL
) -m
0755 $(addprefix $(NCFTP_DIR
)/bin
/, $(NCFTP_TARGET_BINS
)) $(TARGET_DIR
)/usr
/bin
51 $(NCFTP_INSTALL_NCFTP_BATCH
)
54 $(eval
$(autotools-package
))