python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / ncftp / ncftp.mk
blob11bfccaa2546ae65e34b0be72a7c3be1e32ae41c
1 ################################################################################
3 # ncftp
5 ################################################################################
7 NCFTP_VERSION = 3.2.6
8 NCFTP_SOURCE = ncftp-$(NCFTP_VERSION)-src.tar.xz
9 NCFTP_SITE = ftp://ftp.ncftp.com/ncftp
10 NCFTP_TARGET_BINS = ncftp
11 NCFTP_LICENSE = Clarified Artistic License
12 NCFTP_LICENSE_FILES = doc/LICENSE.txt
14 NCFTP_DEPENDENCIES = host-autoconf
15 NCFTP_CONF_OPTS = --disable-ccdv
17 # The bundled configure script is generated by autoconf 2.13 and doesn't
18 # detect cross-compilation correctly. Therefore, we have to regenerate it.
19 # We need to pass -I because of the non-standard m4 directory name, and
20 # none of the other autotools are used, so the below is the easiest.
21 define NCFTP_RUN_AUTOCONF
22 (cd $(@D); $(HOST_DIR)/usr/bin/autoconf -I$(@D)/autoconf_local/)
23 endef
24 NCFTP_PRE_CONFIGURE_HOOKS += NCFTP_RUN_AUTOCONF
26 ifeq ($(BR2_PACKAGE_NCFTP_GET),y)
27 NCFTP_TARGET_BINS += ncftpget
28 endif
30 ifeq ($(BR2_PACKAGE_NCFTP_PUT),y)
31 NCFTP_TARGET_BINS += ncftpput
32 endif
34 ifeq ($(BR2_PACKAGE_NCFTP_LS),y)
35 NCFTP_TARGET_BINS += ncftpls
36 endif
38 ifeq ($(BR2_PACKAGE_NCFTP_BATCH),y)
39 NCFTP_TARGET_BINS += ncftpbatch
40 NCFTP_INSTALL_NCFTP_BATCH = \
41 ln -sf /usr/bin/ncftpbatch $(TARGET_DIR)/usr/bin/ncftpspooler
42 endif
44 ifeq ($(BR2_PACKAGE_NCFTP_BOOKMARKS),y)
45 NCFTP_TARGET_BINS += ncftpbookmarks
46 NCFTP_DEPENDENCIES += ncurses
47 endif
49 define NCFTP_INSTALL_TARGET_CMDS
50 $(INSTALL) -m 0755 $(addprefix $(NCFTP_DIR)/bin/, $(NCFTP_TARGET_BINS)) $(TARGET_DIR)/usr/bin
51 $(NCFTP_INSTALL_NCFTP_BATCH)
52 endef
54 $(eval $(autotools-package))