python-dataproperty: bump version to 0.17.0
[buildroot-gz.git] / package / nmon / nmon.mk
blob9b9f88907813ff2b61d3d993a8f0c6de82286ddf
1 ################################################################################
3 # nmon
5 ################################################################################
7 NMON_VERSION = 16f
8 NMON_SITE = http://sourceforge.net/projects/nmon/files
9 NMON_SOURCE = lmon$(NMON_VERSION).c
10 NMON_LICENSE = GPLv3+
11 NMON_LICENSE_FILES = $(NMON_SOURCE)
12 NMON_DEPENDENCIES = ncurses
13 NMON_CFLAGS = $(TARGET_CFLAGS) -D JFS -D GETUSER -D LARGEMEM -D DEBIAN
15 define NMON_EXTRACT_CMDS
16 cp $(DL_DIR)/$(NMON_SOURCE) $(@D)
17 endef
19 define NMON_BUILD_CMDS
20 $(TARGET_CC) $(NMON_CFLAGS) $(TARGET_LDFLAGS) -o $(@D)/nmon \
21 $(@D)/$(NMON_SOURCE) -lncurses -lm
22 endef
24 define NMON_INSTALL_TARGET_CMDS
25 $(INSTALL) -m 0755 -D $(@D)/nmon $(TARGET_DIR)/usr/bin/
26 endef
28 $(eval $(generic-package))